El 2022-03-28 13:12, Nir Soffer escribió:
On Mon, Mar 28, 2022 at 11:01 AM <nico...@devels.es> wrote:

Hi Nir,

El 2022-03-27 10:23, Nir Soffer escribió:
> On Wed, Mar 23, 2022 at 3:09 PM <nico...@devels.es> wrote:
>> We're running oVirt We have uploaded a qcow2 image
>> (metasploit
>> v.3, FWIW)
> Is it Metasploitable3-0.1.4.ova from the github releases page?
> https://github.com/brimstone/metasploitable3/releases

Actually, the disk has been shared with us by one of our professors. It
has been provided in qcow2, vmdk and raw formats, still the result was
the same. I don't actually know which exact version is it, I just know
the version is "3".

> If not, can you share the image? It will help if we can reproduce this
> problem
> locally with the same image you are using.

I will provide the link off-list because it belongs to the professor.
>> using the GUI (Storage -> Disks -> Upload -> Start). The
>> image is in qcow2 format.
> Did you convert the vmdk file from the ova to qcow2?

Yes, I also tried these steps with the same result.

>> No options on the right side were checked. The
>> upload went smoothly, so we now tried to attach the disk to a VM.
>> To do that, we opened the VM -> Disks -> Attach and selected the disk.
>> As interface, VirtIO-iSCSI was chosen, and the disk was marked as OS,
>> so
>> the "bootable" checkbox was selected.
>> The VM was later powered on, but when accessing the console the
>> message
>> "No bootable device." appears. We're pretty sure this is a bootable
>> image, because it was tested on other virtualization infrastructure
>> and
>> it boots well. We also tried to upload the image in RAW format but the
>> result is the same.
>> What are we missing here? Is anything else needed to do so the disk is
>> bootable?
> It sounds like you converted an image from another virtualization
> system (virtualbox)
> to qcow2 format, which may not be good enough to use the virtual
> machine.
> oVirt supports importing OVA, but based on the UI, it supports only OVA
> created
> by oVirt.
> You can try virt-v2v - this is an example command, you need
> to fill in the {} parts:
> virt-v2v \
>     -i ova {path-to-ova-file} \
>     -o rhv-upload \
>     -oc https://{engine-address}/ovirt-engine/api \
>     -op {engine-password-file} \
>     -on {vm-name} \
>     -os {storrage-domain-name} \
>     -of qcow2 \
>     -oo rhv-cafile={engine-ca-file} \
>     -oo rhv-cluster={cluster-name}
> I tried to import the Metasploitable3-0.1.4.ova, and virt-v2 fails
> with this error:
>     virt-v2v: error: inspection could not detect the source guest (or
> physical machine).
> attached virt-v2v log.

Actually, the professor also provided the OVA from which he extracted
the disk files and the import process in oVirt worked with no issues. I
can now boot the VM, not sure what difference made the OVA but now it

Great that you solved this issue.

For the benefit of the community, can you explain how you imported the OVA?

I uploaded the OVA to one of the hosts. Then in the GUI, went to Compute > Virtual Machines and chose the '...' icon on the right, and clicked on 'Import'. As the source, I chose "Virtual Appliance (OVA)" and wrote down the path of the OVA I uploaded before. Then I just dragged the VM to the right and clicked ok, the import process went perfectly.


Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
List Archives: 

Reply via email to