Hi Mark,
Today I finally managed to solve the problem.
The problem was due to the fact that Windows Authentication was
enabled only at the level of the "s2wweb" virtual folder and not at
the level of the "Jackarta Connector" virtual folder (at the same
level as "s2wweb").
Thanks for the support and sorry for the mistake.

Paolo






















Il giorno lun 19 lug 2021 alle ore 11:21 Mark Thomas
<ma...@apache.org> ha scritto:
>
> On 13/07/2021 16:35, Paolo Clerici wrote:
> >> I don't see any ISAPI redirector set up there. I was expecting to see
> >> something like the steps described here:
> >> http://tomcat.apache.org/connectors-doc/webserver_howto/iis.html
> > Yes, if I have not missed something, I think I have done everything
> > that is written in the document.
> > The only differences are that there are two sites "prod" and "test" so
> > the only differences for "test" are:
> > 1) Dll folder: C:\Apache Software Foundation\Jakarta Isapi 
> > Redirector\test\bin
> > 2) ISAPI filter name: "Jakarta Connector test" (not "tomcat")
> >
> > isapi_redirect.properties file content:
> > extension_uri=/jakarta/isapi_redirect.dll
> > log_file=C:\Apache Software Foundation\Jakarta Isapi
> > Redirector\test\log\mod_jk.log
> > log_level=warn
> > worker_file=C:\Apache Software Foundation\Jakarta Isapi
> > Redirector\test\conf\workers.properties
> > worker_mount_file=C:\Apache Software Foundation\Jakarta Isapi
> > Redirector\test\conf\uriworkermap.properties
> >
> > workers.properties file content:
> > worker.list=dgroupnex02,dgroupnex01
> > worker.dgroupnex02.type=ajp13
> > worker.dgroupnex02.host=10.1.2.93
> > worker.dgroupnex02.port=8009
> > worker.dgroupnex01.type=ajp13
> > worker.dgroupnex01.host=10.1.2.39
> > worker.dgroupnex01.port=8009
> >
> > uriworkermap.properties file content:
> > /S2W/*=dgroupnex02
> > /s2wweb/*=dgroupnex01
> > /websat/*=dgroupnex02
> >
> > I would like to tell you that ISAPI redirection of all virtual folders
> > works perfectly. The only thing that doesn't work is sending the
> > authorization type and user from IIS to Tomcat.
> > The only application that needs this functionality is "s2wweb".
>
> How did you create the s2wweb virtual directory? Please provide exact
> steps. Was is created under the test site or under the jakarta virtual
> directory?
>
> To be honest, I am far from convinced that I have recreated your
> configuration. Receiving the configuration bit by bit and ambiguities in
> the information received (is the test site configured for anon
> authentication, windows authentication or both?) makes me thing at least
> one key bit of information is missing.
>
> Can you provide the complete set of steps required to configure a clean
> IIS 10 install to recreate this issue?
>
> Mark
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
> For additional commands, e-mail: users-h...@tomcat.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org

Reply via email to