On Wed, Oct 20, 2010 at 11:46, [Ricardo Rodriguez] eBioTIC.
<ricardo.rodrig...@ebiotic.net> wrote:
>
>
> Thomas Mortagne wrote:
>> On Tue, Oct 19, 2010 at 21:11, [Ricardo Rodriguez] eBioTIC.
>> <ricardo.rodrig...@ebiotic.net> wrote:
>>
>>> Hi!
>>>
>>> In a XE/XEM 2.4.1 farm, our Lucene building index process stopped as ...
>>>
>>> *Lucene is currently building its index, 41 documents in queue.
>>>
>>> *And we can't access Search in XWiki Preferences of any of the subwikis
>>> or even the controller.*
>>> *
>>> I see this in xwiki.log:
>>>
>>> com.xpn.xwiki.XWikiException: Error number 3301 in 3: Exception while
>>> switching to database redpatrimonio
>>>
>>
>> The only way to have this error I know is to have a
>> XWiki.XWikiServerRedpatrimonio page with a wiki descriptor object and
>> no corresponding database.
>>
>>
>>> Wrapped Exception: Unknown database 'redpatrimonio'
>>>    at
>>> com.xpn.xwiki.store.XWikiHibernateBaseStore.setDatabase(XWikiHibernateBaseStore.java:643)
>>>    at
>>> com.xpn.xwiki.store.XWikiHibernateBaseStore.beginTransaction(XWikiHibernateBaseStore.java:742)
>>>    at
>>> com.xpn.xwiki.store.XWikiHibernateStore.loadXWikiDoc(XWikiHibernateStore.java:683)
>>>    at
>>> com.xpn.xwiki.store.XWikiCacheStore.loadXWikiDoc(XWikiCacheStore.java:289)
>>>    at com.xpn.xwiki.XWiki.getDocument(XWiki.java:1463)
>>>    at com.xpn.xwiki.XWiki.getDocument(XWiki.java:1506)
>>>    at com.xpn.xwiki.api.XWiki.getDocument(XWiki.java:166)
>>>    at com.xpn.xwiki.api.XWiki.getDocument(XWiki.java:153)
>>>    at com.xpn.xwiki.plugin.lucene.SearchResult.<init>(SearchResult.java:98)
>>>    at
>>> com.xpn.xwiki.plugin.lucene.SearchResults.getRelevantResults(SearchResults.java:72)
>>>    at
>>> com.xpn.xwiki.plugin.lucene.SearchResults.getHitcount(SearchResults.java:22
>>>
>>>
>>> In fact, that database is called redepatrimonio, not redpatrimonio.
>>>
>>> The wiki descriptor page name in the main wiki is
>>> XWiki.XWikiServerRedepatrimonio.
>>>
>>
>> Are you sure you don't have XWiki.XWikiServerRedpatrimonio too.
>>
>
> I think I haven't it. Please, see...

I think you used to have it and it has been removed but lucene plugin
did not see that and now you have document in lucene index that don't
exists. Try to recreate the lucene index.

>
> http://ebiotic.net/bin/ICT/Subwikis
>>
>>> Please, where the name of the database as listed in the exception is
>>> stored? How could I correct it?
>>>
>>> I don't know how I've messed things and if this error is related with
>>> problem, but it seems that need to be corrected before trying anything else!
>>>
>>
>> In any case, it's also a Lucene plugin bug since a ghost wiki should
>> not break it, would be nice if you could report it on
>> http://jira.xwiki.org.
>
> I'm doing some more research. I'll create a JIRA issue with the results.
>
> Thanks!
>
> Ricardo
>
> --
> Ricardo Rodríguez
> CTO
> eBioTIC.
> Life Sciences, Data Modeling and Information Management Systems
>
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>



-- 
Thomas Mortagne
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to