On Mon, Aug 22, 2016 at 4:50 PM, Eugen Colesnicov <ecolesni...@gmail.com> wrote:
> I am trying to install xwiki on Debian 8.5 using Debian packages.
>
> I made commands (according to instruction):
> 1) wget -q "http://maven.xwiki.org/public.gpg"; -O- | apt-key add -
> 2) wget "http://maven.xwiki.org/stable/xwiki-stable.list"; -P
> /etc/apt/sources.list.d/
> 3) sudo apt-get update
> 4) apt-cache search xwiki - all ok, I see xwiki packages
>
> When I trying to install -
> 5) apt-get install xwiki-enterprise-tomcat8-mysql
> but result is:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  xwiki-enterprise-tomcat8-mysql : Depends: xwiki-enterprise-mysql-common (=
> 8.2.1) but it is not going to be installed
>   Depends: xwiki-enterprise-tomcat8-common (= 8.2.1) but it is not going to
> be installed
> E: Unable to correct problems, you have held broken packages.
>
> What is the problem and how I can correct it?

When you get an error like this (which does not really say much in
practice) you can try to install the package that "is not going to be
installed" to get more detail on why it's not going to be installed.

I don't know Debian 8.5 very well (mostly using Ubuntu on my side) but
the cause of error like this is often one (or all) of the following:
* this Debian version does not provide any tomcat8 package in which
case the fix is to use xwiki-enterprise-tomcat7-mysql package instead
* this Debian version does not provider any openjdk-8-jre-headless
package in which case the fix is to install yourself some Java 8 JVM
(http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html
is nice for this). In short you need to make sure you install a
package that provide one of the following features:
java8-runtime-headless, java8-runtime or openjdk-8-jre-headless.

>
>
>
>
> --
> View this message in context: 
> http://xwiki.475771.n2.nabble.com/Debian-installation-failed-tp7600759.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users



-- 
Thomas Mortagne
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to