https://codereview.chromium.org/12314155/diff/23001/src/assembler.cc
File src/assembler.cc (right):
https://codereview.chromium.org/12314155/diff/23001/src/assembler.cc#newcode1166
src/assembler.cc:1166:
Two empty newlines between functions. Also one occurrence above and one
below.
https://codereview.chromium.org/12314155/diff/23001/src/code-stubs-hydrogen.cc
File src/code-stubs-hydrogen.cc (right):
https://codereview.chromium.org/12314155/diff/23001/src/code-stubs-hydrogen.cc#newcode170
src/code-stubs-hydrogen.cc:170: AddInstruction(new(zone)
HAllocate(context(),
Either keep the old line-breaks or also move the context() onto the next
line.
https://codereview.chromium.org/12314155/diff/23001/src/flag-definitions.h
File src/flag-definitions.h (right):
https://codereview.chromium.org/12314155/diff/23001/src/flag-definitions.h#newcode166
src/flag-definitions.h:166: DEFINE_bool(pretenure_objects, false,
"pretenure objects")
This flag is very ambiguous, how about calling it pretenure_literals? Or
at least make the description string more explanatory.
https://codereview.chromium.org/12314155/diff/23001/src/hydrogen.cc
File src/hydrogen.cc (right):
https://codereview.chromium.org/12314155/diff/23001/src/hydrogen.cc#newcode1061
src/hydrogen.cc:1061: if (FLAG_pretenure_objects) {
This is incorrect for fast-double elements kind as it would allocate the
FixedDoubleArray backing store in old-pointer-space instead of
old-data-space.
https://codereview.chromium.org/12314155/
--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
---
You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/groups/opt_out.