Spent the last day trying to solve this, but I keep hitting a brick wall.

I upgraded to Vagrant 2.0.2.

OSX 10.13.4 Beta.

Virtualbox 5.2.6 r120293 (Qt5.6.3)

I have Vagrant installed in the standard way. And a number of projects in 
individual folders in my User directory. I was trying to set up a new 
project and I ran into this:

Vagrant failed to initialize at a very early stage:
> The plugins failed to load properly. The error message given is
> shown below.
> Could not locate Gemfile or .bundle/ directory


I have tried vagrant plugin repair

I have tried vagrant plugin expunge --reinstall

These are the plugins I have:

bundler (1.16.1)
hostupdater (1.0.0)
vagrant-gatling-rsync (0.9.0)
vagrant-plugin-bundler (0.1.1)
vagrant-share (1.1.9, system)
vagrant-triggers (0.5.3)
vagrant-vbguest (0.15.1) 

When I try vagrant up in my project, I get the error above.

I tried uninstalling Vagrant from command line and reinstalling. No 
difference.

I tried downgrading to Vagrant 2.0.1. No difference.

I updated Command Line Tools for Xcode, even though I never use any of that.

Basically, I have no clue why I cannot get Vagrant to work at all.

I searched the web and read everything I could on "Could not locate Gemfile 
or .bundle/ directory". I'm not finding anything that helps.

So I come back here.

Can someone point me in the right direction?




Thanks in advance for any assistance.

best,
ian

-- 
This mailing list is governed under the HashiCorp Community Guidelines - 
https://www.hashicorp.com/community-guidelines.html. Behavior in violation of 
those guidelines may result in your removal from this mailing list.

GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
--- 
You received this message because you are subscribed to the Google Groups 
"Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to vagrant-up+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/vagrant-up/9cf140a1-0e0d-4d06-a09f-61d8d508d662%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to