I'm rebuilding a dinosaur mail server that I built a couple years ago. 
It's running vpopmail 4.9.10 using cdb authentication. I'm upgrading to 
5.3.8 with MySQL authentication.

I've build out the new 5.3.8 system and cluster of machines. It's all 
up, running and happy. I've NFS mounted all the home directories from 
the old cluster onto the new system so that I have ready access to the 
vpasswd and vpasswd.cdb files. They are mounted onto the local 
filesystem so that the paths in /var/qmail/users/assign are correct.

I run vconvert -c -m test.domain.com and it exits quietly indicating 

mail8# ~vpopmail/bin/vconvert -c -m -v -d test.simerson.net
version: 5.3.8
converting test.simerson.net done

However, when I check the MySQL server, there's no entries in the 
vpopmail table that correspond to that domain. :-(

I've tested this one step further. I've manually added a valid user 
([EMAIL PROTECTED]) into the new mail system by manually adding it 
into the MySQL table. It works fine, authenticates, etc. That basically 
makes it work with my new mail system and the old one at the same time. 
Cool.  Anyway, if I run vconvert again, it'll actually delete that 
entry from the vpopmail table.  Is that supposed to happen?

Everything on the new system works just fine except the vconvert 
function. Can anyone verify that vconvert actually does work?  Can you 
sanitize a copy of a newer vpasswd file and send it my way so I can 
compare it to my ancient system to see if the format is still the same?


Reply via email to