I recently setup a vpopmail + qmail + sqwebmail box.

NOTE: I may be confusing some of the following suggestions with courier-imap
install issues I had. Sorry if im off here.


I had to 'chown root.root /home/vpopmail/bin/vchkpw'.


Also, try this:

make the 'authmodulelist=' line in
/usr/local/sqwebmail/authdaemonrc look like:

Because I think sqwebmail gets confused if authvchkpw is not first in the
list, as earlier entries take precedence for authorization, and any othe
authmodules you may have compiled may be complicating the situation. See
next suggestion.


/usr/local/src/vpopmail-5.2.1# ./configure --help |grep sqwebmail  :
"  --enable-sqwebmail-pass=y|n   Turn on support for sqwebmail passwords (y)
or off (n) default is no. For sqwebmail-3.0 and above use default no"

Try to explicitly set all configure options, especially auth options for
both sqwebmail and vpopmail:

/usr/local/src/vpopmail-5.2.1# ./configure --help
/usr/local/src/sqwebmail- ./configure --help

like for sqwebmail:
./configure --with-(only module you need probably
authvchkpw) --without-(everything you dont need)
and etc for vpopmail.

These suggestions may help. Please let me know if they do.


----- Original Message -----
>From: "Nathan Chan" <[EMAIL PROTECTED]>
>Sent: Monday, December 30, 2002 4:57 PM
>Subject: [vchkpw] Upgrading Vpopmail to 5.2.1 and Auth Now Fails

>G'Day All,
>I have had a stable and working qmail + vpopmail + qmailadmin +
>sqwebmail system running for some 2 years now except for one
>little prob under sqwebmail for quota's.  Upon reading some info i
>believe this quirk is now gone under sqwebmail in the new versions
>but to do that upgrade of course i need to upgrade vpopmail, which
>was fine, except that the new version won't auth anyone with the
>new vchkpw...
>Info for system below :
>Qmail 1.03 (of course)
>my configure line for the new vpopmail (5.2.1) is :
>./configure --enable-ip-alias-domains=y --enable-logging=e --enable-
>vpopuser=vpopmail  --enable-md5-passwords=y --enable-
>defaultquota=20M --enable-clear-passwd=n
>(i have tried with enable-clear-passwd=y but no difference.)
>I run Qmail under tcpserver as follows :
>tcpserver -R -H 0 pop3 /var/qmail/bin/qmail-popup
>domainxyz.com.au /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-
>pop3d Maildir&
>The domains all have their vpasswd/vpasswd.cdb files, but for some
>reason when i update the vchkpw it fails to auth.  As soon as i
>revert no probs.
>Any help would be greatly appreciated.
>Out the 100TX, through the switch, down the cable modem, over the fiber
>optics, off the bridge, past the head end office.... nothing but 'Net.

Reply via email to