hi,Jens:
    I did guess that you should be off for your business trip or holidays ,  :-)
    I think basedn and binddn is the same in my vldap.h and slapd.conf, and if i have 
the below entry tree in my openldap through ldapbrowser:

   dc=koal,dc=com
       |
         ->ou=people
            |
             -> ou=net.koal.com
                 |->uid=postmaster
                  ->uid=test

and my slapd.conf:
    
database        ldbm
suffix          "dc=koal,dc=com"
rootdn          "cn=root,ou=people,dc=koal,dc=com"
rootpw  xxxxx ( here is the same with the password in vldap.h)

and my vldap.h:

#undef OLD_VLDAP

#define VLDAP_SERVER "localhost"
#define VLDAP_PORT LDAP_PORT
#define VLDAP_USER "cn=root,ou=people,dc=koal,dc=com"
#define VLDAP_PASSWORD "xxxxx" ( here is the same with the password in slapd.conf)

#define MAX_BUFF 500

#ifdef OLD_VLDAP
   #define VLDAP_BASEDN "ou=Subs, o=vpop"
#else
   #define VLDAP_BASEDN "ou=people,dc=koal,dc=com"
#endif

I test the pop3 authentication  :

[EMAIL PROTECTED] root]# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK <[EMAIL PROTECTED]>
user test
+OK 
pass test
Error: No such object
        matched DN: "ou=people,dc=koal,dc=com"
-ERR authorization failed
Connection closed by foreign host.

and then maillog reports:

Jul 16 14:39:29 mailserver vpopmail[1244]: vchkpw-pop3: vpopmail user not found 
test@:127.0.0.1


if i test the pop3 with a domain that doesn't exsits :

[EMAIL PROTECTED] root]# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK <[EMAIL PROTECTED]>
user [EMAIL PROTECTED]
+OK 
pass test
Error: No such object
        matched DN: "ou=people,dc=koal,dc=com"
-ERR authorization failed

then maillog reports:

Jul 16 14:42:06 mailserver vpopmail[1261]: vchkpw-pop3: vpopmail user not found [EMAIL 
PROTECTED]:127.0.0.1

it seems that i should submit the correct and complete email add:  [EMAIL PROTECTED]


then i test :

[EMAIL PROTECTED] root]# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK <[EMAIL PROTECTED]>
user [EMAIL PROTECTED]
+OK 
pass test
-ERR aack, child crashed

and then maillog reports nothing about this failed login.

it seems that the vchkpw has recognized this [EMAIL PROTECTED]
,but child crashed error is occured. 
what's happened?  




Reply via email to