----- Original Message ----- 
From: "Jonas Pasche" <[EMAIL PROTECTED]>

> Please define "is not working". What did you do, what did the computer
> do, what did you expect it to do? What did you check, and how did you
> check it?

Sorry, I'll try and deepen my steps:

Aftter backing up my box (which failed miserably and I had to do a 'service
smb stop') my pop3 client got errors.

I've checked :
/service/qmail-pop3d: up (pid 4237) 2723 seconds
/service/qmail-pop3d/log: up (pid 1051) 15160 seconds
/service/qmail-pop3ds: up (pid 4242) 2723 seconds
/service/qmail-pop3ds/log: up (pid 1048) 15160 seconds

to see if they're stopping/restarting constantly. They were not.

Then tried connecting with both pop3 and IMAP, to see if it was vchkpw, that
was the problem. both use it:

telnet localhost 110
Connected to localhost.
Escape character is '^]'.
pass xxxxxxx
-ERR authorization failed
Connection closed by foreign host.

telnet localhost 143
Connected to localhost.
Escape character is '^]'.
* OK Courier-IMAP ready. Copyright 1998-2002 Double Precision, Inc.  See
COPYING for distribution information.
a001 login [EMAIL PROTECTED] xxxxxxx
a001 OK LOGIN Ok.
a001 logout
* BYE Courier-IMAP server shutting down
a001 OK LOGOUT completed
Connection closed by foreign host.

Then I tried a diff on the qmail-popup to see if the file there was damaged,
but they match with original file.

Then I tried to see if my pop3d logfile was producing anything funny, but
everything seems fine.

And checking the procedures in the /var/qmail/supervise/qmail-pop3d/run


VPOPMAILUID=`id -u vpopmail`
VPOPMAILGID=`id -g vpopmail`

exec /usr/local/bin/tcpserver -l 0 -R -H -v             \
        -u"$VPOPMAILUID" -g"$VPOPMAILGID" 0 110       \
        /var/qmail/bin/qmail-popup fizban.netformidling.dk    \
        /home/vpopmail/bin/vchkpw                       \
        /var/qmail/bin/qmail-pop3d Maildir 2>&1

shows that it looks like it should.

Therefore, I'm a bit clueless right now. If it is permissions on the
qmail-popup, vchkpw, then here :

-rwx--x--x    1 root     qmail       12480 Apr  3 11:11
-rw---x--x    1 vpopmail vchkpw      45264 Apr  3 11:19

I've also done a :

chown -R /home/vpopmail/domains

as suggested on google, whebn i searched for answers

I hope I included enough info.


Reply via email to