Title: Message
 Thanks for the reply. That has fixed the problem. Compiles now, and it works still with
the mysql backend.
-----Original Message-----
From: tonix (Antonio Nati) [mailto:[EMAIL PROTECTED]
Sent: Monday, 1 September 2003 5:05 AM
Subject: Re: [vchkpw] 5.3.26 error with chkusr patch + mysql


I did not try the last versions of vpopmail.

It looks like function vget_real_domain does not exists anymore.

Try commenting out these lines of code, and please let me know.

/* Check if domain is a real domain */
        if (!stralloc_0 (&domain)) die_nomem();
        vget_real_domain(domain.s, domain.a);
        domain.len = strlen (domain.s);
        if (domain.len > (domain.a - 1)) die_nomem();
/* Let's get domain's real path */


At 01/09/03 01/09/03 +0800, Shane Chrisp wrote:
 Im setting up a new system and I found that there is an error when
trying to use the chkusr patch with the latest version. Below is the
error from qmail. I tried compiling again with 5.3.24 successfully
so I then tried 5.3.25 and that failed also, with the same error.

./load qmail-smtpd qregex.o rcpthosts.o commands.o timeoutread.o \
timeoutwrite.o ip.o ipme.o ipalloc.o control.o constmap.o \
received.o date822fmt.o now.o qmail.o cdb.a fd.a wait.a \
datetime.a getln.a open.a sig.a case.a env.a stralloc.a \
alloc.a substdio.a error.a str.a fs.a auto_qmail.o base64.o  `cat \
socket.lib` -lssl -lcrypto dns.o `cat dns.lib` -lcrypt \
`head -1 conf-vpopmail`/lib/libvpopmail.a \
/usr/lib/mysql/libmysqlclient.a -lz
qmail-smtpd.o: In function `realrcpt_check':
qmail-smtpd.o(.text+0xf29): undefined reference to `vget_real_domain'
collect2: ld returned 1 exit status
make: *** [qmail-smtpd] Error 1



        [EMAIL PROTECTED]            Interazioni di Antonio Nati
   http://www.interazioni.it      [EMAIL PROTECTED]          

Reply via email to