Joseph Kacmarcik wrote:

hi list!

so... i've read a number of posts, looked in a number of places, compiled
and recompiled numerous times, but i can't get qmail/vpopmail/courier on
linux to write to an sql relay table. everything works except this part. i
can authenticate and receive via pop or imap, and either over ssl. i can
send using webmail on the local system.

i used the same patches and the same configure concoctions to compile the
same software on two different freebsd boxes and it works fine (please
don't ask why i don't just use the bsd boxes).

so, here's my configure lines:

no patches to vpopmail. i started with 5.3.23 and am on 5.3.27 now with
the same results

/usr/local/src/vpopmail-5.3.27
./configure --enable-mysql=y --enable-roaming-users=y \
--enable-defaultquota=1073741824S,100000C --enable-learn-passwords=y \
--enable-logging=p --enable-mysql-logging=y --enable-qmail-ext=y

no patches for courier imap. started with 2.1.1, am using 2.1.2 now.

/usr/local/src/courier-imap-2.1.2
./configure --prefix=/usr/local --exec-prefix=/usr/local --without-authldap \
--without-authshadow --with-authvchkpw --without-authcram \
--sysconfdir=/usr/local/etc/courier-imap \
--datadir=/usr/local/share/courier-imap \
--libexecdir=/usr/local/libexec/courier-imap \
--enable-workarounds-for-imap-client-bugs --disable-root-check \
--without-authdaemon --with-redhat


my qmail-smtpd startup is: (variables are handled in the script) exec softlimit -m 8000000 tcpserver -S -R -H -c100 -x /usr/local/vpopmail/etc/tcp.smtp.cdb -u $QMAILUID -g $NOFILESGID 0 smtp qmail-smtpd salo.chubbo.net /usr/local/vpopmail/bin/vchkpw /usr/bin/true splogger smtpd

have tried removing path to tcp.smtp.cdb too.

/var/qmail/control/sql
server localhost
port 3306
database vpopmail
table relay
user vpopmail
pass password
time 1800

~vpopmail/etc/vpopmail.mysql
localhost|0|vpopmail|password|vpopmail
localhost|0|vpopmail|password|vpopmail

i'm logging mysql traffic for debugging and i don't see any inserts into
the relay table, only selects and deletes (from cron).

ucspi was patched with mr simerson's ucspi-tcp-0.88-mysql3+rss.patch
although i have tried ucspi-tcp-0.88-mysql+rss.patch with the same
results.

i really hope i'm stupid this year and it's a simple thing, but i can't
figure it out.

thoughts and helpful comments appreciated.

thanks in advance!
joe







I cant help you on the problem about it not adding entries, but have you considered using a qMail auth patch for outgoing, so clients can AUTH to send mail. This would do the same thing, and would work as you intended, to let someone relay.





Reply via email to