Ok,

All I want to do is invoke maildrop from .qmail-default for some domains, and 
have maildrop read the users homedirs from the mysql db.

Apparantly, it doesn't work. I tried virtually everything. I added the -V 9 
option to maildrop for debugging, and it always says:

@400000003f7d5922332596fc delivery 9: deferral: 
maildrop:_Changing_to_/home/vpopmail/Message_start_at_0_bytes,_envelope_sender=
vpopmail/maildrop:_Attempting_.mailfilter/maildrop:_Delivering_to_/var/mail/vpo
pmail//usr/local/bin/maildrop:_Unable_to_open_mailbox./

when it should be really changing 
to /home/vpopmail/domains/somedomain.com/someuser

Here is my current config:

./configure     --prefix=/usr/local \
                --with-etcdir=/usr/local/etc \
                --enable-maildrop-uid=root \
                --enable-maildrop-gid=wheel \
                --without-db \
                --enable-maildropmysql \
                --with-mysqlconfig=/usr/local/etc/maildropmysql.conf \
                --enable-maildirquota

I made sure it's suid r00t:
# ll /usr/local/bin/maildrop
-rwsr-sr-x   1 root     wheel      833435 Oct  3 01:17 /usr/local/bin/maildrop


# cat /usr/local/etc/maildropmysql.conf | grep -v "^#" | grep -v "^$"
hostname        mysqlhost
port            3306
database        vpopmail
dbuser          vpopmail
dbpw            mysecretpw
dbtable         vpopmail
default_uidnumber       500
default_gidnumber       500
uid_field               pw_email
homedirectory_field     pw_dir
quota_field             pw_shell


(pw_email is a column that I created in the vpopmail table that concats two 
columns, pw_name and pw_domain, with '@' in between them - and I simulated 
maildrop's select query and it works quite well) I even tried putting "CONCAT
(pw_name, '@', pw_domain) AS pw_email" as the uid_field in maildropmysql.conf
This doesn't seem to affect it a bit.

# id vpopmail
uid=500(vpopmail) gid=500(vchkpw) groups=500(vchkpw)

# cat .qmail-default
| /usr/local/bin/maildrop -V 9


I tried changing .qmail-default to:

# cat .qmail-default
| /usr/local/bin/maildrop -V 9 -d [EMAIL PROTECTED]

But I get this in my qmail-send logs:

@400000003f7d635e28877ef4 delivery 4: deferral: Invalid_user_specified./


How do I convince maildrop that I am just delivering to the virtual users 
homedir/Maildir and not trying to start WWIII?

I hope I don't have to use that trusted-user related options.

The reason is because all my domains right now run under 1 uid (i.e. virtual) 
and i would like to later add a few domains each with its unique uid.
Therefore, I wouldn't like to recompile maildrop everytime I needed to add a 
new trusted user..

Any info would be helpful..

thanks,
tim

Reply via email to