Hello,

I am trying to setup an email system and use Sqwebmail as a web-based frontend. I am doing this on a Gentoo box. I have installed Qmail, Vpopmail and Courier-IMAP via gentoo's portage system. I have it all configured and sending/receiving email properly (from what I can tell) by following the doc at:

http://www.gentoo.org/doc/en/qmail-howto.xml

The doc recommends installing "Horde / IMP Webmail" for web-based email but I liked sqwebmail better because it directly accesses the Maildir files instead of going through POP or IMAP. So I went about trying to get sqwebmail installed (an there currently does not exist a portage package for this).

I am building sqwebmail without authdeamon support because the Courier-IMAP package already installs the authdeamon with it. The package builds and installs fine. The sqwebmail service starts up and I get the login screen when I execute the CGI script through apache. I type in my login information and it appears to login successfully but gets an error when it tries to find my Maildir folders. The following is the error message I get:

Unable to open the maildir for this account -- the maildir doesn't exist or has incorrect ownership or permissions.

I was thinking that perhaps this is because gentoo uses the name ".maildir" instead of "Maildir" to store the mail files. I looked in the auth.c file for my error message and found the following line:

if (login_maildir(getenv("MAILDIR")))
error("Unable to open the maildir for this account -- the maildir doesn't exist or has incorrect ownership or permissions.");


So my thought is to set the MAILDIR environment variable to match Gentoo's setup. So I put the following line in my Apache conf for this particular virtual host:

SetEnv MAILDIR .maildir

Despite my efforts to point it to the correct place I still get the same error message. So I am stuck. My questions are:

1) Am I even asking this question to the correct group. The sqwebmail docs said to ask any questions that relate to vpopmail to this list.
2) Is there something I am missing. I want it to login to my mailbox under vpopmail. The authentication module it is using is the authvchkpw and it seems to be at least authenticating.
3) Any suggestions?


I greatly appreciate any help that I can get (or simply a pointer to the correct place to ask this).

Thanks,

Eric



Reply via email to