Nah.  You did it the right way.  That's how I would have done it.  I
just moved everything to a new server and did it by exporting and
importing the SQL data.  I recall doing a mysql to PostgreSQL conversion
once and just did an export and import.
Is there anything in the log files?  /var/log/mail/info or
/var/log/mail/errors ... how about in /var/log/qmail/pop3d/current?
If vuserinfo is working, then your database hooks in vpopmail are all
ok.  How about doing a make clean and make and make install again?  Then
restart qmail.

If you're using daemontools
   svc -du /service/qmail-pop3d

How about if you telnet to the server on port 110 and try to auth by
hand?  You sure it's not a Thunderbird issue?

If you're doing IMAP, then try recompiling the authdaemon.  I believe
it's a separate package now from Courier.

I had some issues at one point and I ended up deleting everything in
~vpopmail/etc ~vpopmail/include ~vpopmail/bin and ~vpopmail/lib then
rebuilt vpopmail and rebuilt authdaemon.  Then it all worked.



        From: Joshua Coucke [mailto:[EMAIL PROTECTED] 
        Sent: Thursday, March 31, 2005 11:53 AM
        Subject: Re: [vchkpw] Switching from Mysql to Postgresql

        Charles J. Boening wrote: 

                I'm using vpopmail 5.4.10 successfully with PostgreSQL.
                How about permissions for your vpopmail sql user?  Did
you GRANT that
                user permissions to the database?

        Yes, the user does have permissions. 

                How about running the commandline utilities?
                /home/vpopmail/bin/vuserinfo <email addy>

        I was able to get userinfo on an email address.  And I was able
to verify that the info was coming from the postgres db.  (I changed
some info in the db and ran the command again, the output was updated.)
        name:   jdcoucke
        passwd: $1$39sHL0$r3PDZJzvwbTAKOxJD4HHq.
        clear passwd: ******
        comment/gecos: Joshua Coucke
        uid:    0
        gid:    4096
        flags:  4096
        gecos: Joshua Coucke
                has qmailadmin administrator access
        dir:       /home/vpopmail/domains/

        quota:     4194304S
        usage:     0%
        NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index
"lastauth_pkey" for table "lastauth"
        last auth: Never logged in
        Thunderbird still returns an auth error.
        All of user info was imported from a mysql db using phpmyadmin
and imported using phppgadmin.  Would it make a difference if I used
vconvert instead?

                        -----Original Message-----
                        From: Joshua Coucke
                        Sent: Thursday, March 31, 2005 7:08 AM
                        Subject: [vchkpw] Switching from Mysql to
                        I used the QMR install with the MySQL option to
                        vpopmail.  Now, however,  I need to switch from
MySQL to 
                        PostgreSQL as the backend for the whole thing.
The problem I 
                        am having is that when I recompile vpopmail to
use PostgreSQL 
                        and then procede to check my email I get an
error telling me 
                        that authorazation failed.
                        As far as I can tell I have provided the correct
username and 
                        database for vpopmail in the vpgsql.h file.  And
I have 
                        imported into postgres the database from mysql.
                        The other odd thing is that vqadmin and
qmailadmin still seem 
                        to be using the mysql database after recompiling
vpopmail for 
                        use with postgres.
                        I am using vpopmail v5.4.10, postgres v8.0.1,
and Fedora Core 3.
                        Any ideas on the subject would be helpful.
                        I tried to google for this but nothing came up.
                        Joshua Coucke


Reply via email to