Patrick Donker wrote:
Hi people,

I am having ./configure problems using  mysql as authmodule. This is my
./configure \
--enable-vpopuser=$VPOPUSER \
--enable-vpopgroup=$VPOPGROUP \
--enable-roaming-users \
--enable-tcprules-prog=$TCPRULES \
--enable-relay-clear-minutes=$ENABLE_RELAY \
--enable-sqwebmail-pass \
--enable-qmail-ext \
--enable-ip-alias-domains \
--enable-domainquotas \
--enable-auth-module=$DATABASE_TYPE \
--enable-logging=p \
--enable-auth-logging \
--enable-valias \
--enable-sql-logging \
--enable-clear-passwd \
--enable-mysql-limits \

And this is the error:

checking whether an auth module has been specified... mysql
configure: error: Unable to find your MySQL lib dir, specify
./ line 1082: --enable-libdir=/usr/include/mysql: No such file
or directory
make: *** No targets specified and no makefile found.  Stop.
Error with vpopmail's installation (make)

All variables are correctly filled, the only error I get is about mysql
libdir. I have tried every version from 5.4.10 and up. My mysql version
is 4.1. What is it exactly configure is looking for? I dont know which
lib supposedly is missing, so I cant check either. How to troubleshoot
this? The dir /usr/include/mysql exsist. I also already have tried /usr/lib.


It's looking for the mysql libs, not includes. On some of my systems it's in /usr/lib/mysql, in others it's in /usr/local/mysql/lib

A locate libmysqlclient.a should show you where yours is.

PS - domainquotas do not work.



Reply via email to