i wrote to the list about a month ago - i'm migrating our entire company to new servers in a new location. i've tackled the data migration with no problems - rsync is your friend - but i've run up on a weird problem while testing the new server (which has all the mysql db's and everything else in place - the new server is identical to the old one, so all binaries were copied over).

i performed a pop3 connection on the command line from a remote server to the new server to ensure authentication was working. i tried my own login - worked fine. however, i then tried a random customer's login - and it crashed. my account and the customer's account are identical in all other respects. but when i entered the password:

pass theirpass
-ERR aack, child crashed

urk. so, on a hunch, on the new server i ran 'vpasswd theirpass' - exact same password. and after doing that, it worked fine.

what am i missing here? is there some sort of 'salt' to the passwords that needs to be reset now that they're on a new server? if so, i'm in for some ugliness if every password has to be reset by hand.

i tried trussing (this is solaris) the process, but couldn't see what specifically was causing the problem.

Paul Theodoropoulos

Reply via email to