You're going to need to provide more details Christoph. I personally
don't use either qmail's POP3 or Dovecot (yet), but I've been running
POP3s and IMAP4s for many years with courier. If it's not working, your
logs should give you an idea why. Typically you have to compile support
in. I know you do with Courier. I can't see Dovecot being any different.

The TLS patch you're talking about has nothing to do with POP3 or IMAP.
And as far as I know, vpopmail doesn't really play into it either (or at
least not that much...but I might be wrong). 

For qmail POP3 look up how to setup recordio (part of the ucspi-tcp
package) in your POP3 startup so you can get the full conversation. Also
try posting your run file for POP3. As far as I know all you need to run
POP3s is stunnel, a certificate, and a proper setup. There's plenty of
guides around if you google.

I'm sorry I can't help with Dovecot, but their mailing list I'm sure
would be please to point you in the right direction, which will probably
be their documentation wiki :)

Hope that helps,


> -----Original Message-----
> From: ckubu []
> Sent: Sunday, May 10, 2009 5:42 AM
> To:
> Subject: [vchkpw] non plaintext authentication methods
> hi,
> I'm running qmail+vpopmail+dovecot on FreeBSD stable system and all
> worked
> fine, almost all. I'm not able to bring non-plaintext authentication
> methods
> working on qmails pop3 service (APOP), and on dovecots imap service
> (CRAM-MD5).
> Maybe this is an OS issue and this question isn't on he right place
> here, in
> this case sorry about that.
> my versions:
> (net)qmail with tls-smtp-auth patch
> vpopmail 5.4.27
> dovecot 1.1.14
> i have tried older versions of vpopmail and dovecot, but with the same
> result:
> non-plaintext authentication methods doesn't work.
> what did i wrong ? can aybody help me ?
> regards christoph


Reply via email to