On 06/21/2013 08:54 PM, Jeremy Kister wrote:
I have qmail 1.03 with several patches including qmail-smtpd-auth-0.4.3
and vpopmail 5.4.33.

After upgrading Debian 6 -> 7, I broke SMTP-AUTH *only* when using
stunnel for SSL.

When trying to auth over stunnel4, i see:
454 oops, problem with child and I can't auth (#4.3.0)

syslog shows:
Jun 21 23:19:29 s4 vpopmail[3080]: vchkpw-smtps: (PLAIN) login success

using smtp-auth on port 25 or 587 works fine.


i modified smtps.conf to use strace like:
exec = /usr/bin/strace
execargs = /usr/bin/strace -ff -o /tmp/vchkpw.dump
/var/qmail/bin/qmail-smtpd /home/vpopmail/bin/vchkpw /bin/true

the dumps are at:

i tried increasing & just removing softlimit.
i tried recompiling/reinstalling vpopmail

I dont think the problem is with stunnel since the SSL layer is working

I'm out of ideas.  More eyes please ?

It seems peculiar to me that the log shows login success, but the oops message says it can't auth. I'm not very familiar with the inner workings of vpopmail though.

Have you found where in the code the "oops" messages is being issued?

-Eric 'shubes'


Reply via email to