Your right - we're in the slow process of putting documentation at the Apache wiki:

Please note this is going to be the official location.

A rough outline of the documentation organization.

With the steps to create a base XP image:

We'll be fine tuning and stream lining these steps as we move forward.

Likely with the two methods in mind:
1) a perl based capture_image script, that would do most if not all of the step 8 ssh service is installed and configured.
2) using the web interface to capture a image from a node

Yes there is a set of post load scripts or logon scripts that the root account runs during the autologon process.
These are outlined in steps 13 and 14


--On April 14, 2009 4:59:39 PM -0400 Melba Lopez <> wrote:

Initially after deploying our XP image, RDP continued to refuse connection
using the credentials given in the VCL web interface.  We later found this
link (not mentioned in the wiki), that requires you to enable remote
connection. (Perhaps this should be added to the wiki?)

3. Setup environment (most of following are recommendations just to create
default configuration):
- go to Start->My Computer->right click and choose "Show on Desktop"
- in "System Properties" (Start->My Computer->right click->Properties)
under "Remote" tab, check "Allow users to connect remotely to this
computer" - IMPORTANT!

After enabling this setting and redeploying, we encountered a new error
where admin logs you in momentarily and quickly logs you out of the

I tried this several times, even redoing the image to ensure I followed
the steps in the wiki, but I see the same result along with some
inconsistencies in between.  I've encountered 2 different scenarios more
than once (with the same base image unchanged):

Scenario 1:
Once the VM is booting, root gets logged in and it runs its scripts.
 Because of the VCLprepare.cmd script, it should automatically log off
root, but in this scenario, this does not happen.  Thus, I go and log off
root manually.  I then see the "admin" account in the gui.  I try to RDP
with the credentials (and try the downloaded rdp file), and it will
quickly log me in and out.

Scenario 2:
VM boots up and root logs in, runs scripts and logs out.  The gui only
shows root and does not show an "admin" account.  I try to RDP with the
credentials (and try the downloaded rdp file), and it will quickly log me
in and out.  When I reboot the VM, the admin account now shows up in the
gui.  Using the downloaded rdp file, it gives me an error connecting to
the VM.  I then try using RDP manually, I'm able to login to admin, but
it quickly logs me out.

What scripts are being run at admin logon?  Is there a script or a
setting I forgot to implement?

Melba Lopez

Aaron Peeler
OIT Advanced Computing
College of Engineering-NCSU

Reply via email to