I've updated the wiki to include changes that we discussed that allowed me
to have a successful XP deployment.


Summary of Changes:

   - Added "Setup environment for Remote Access".
      -  Without this, the user is unable to RDP into the admin account VCL
      - Moved VCL Sysprep scripts to the end of the section AFTER
   - If done before, scripts will log you out of root during setup.
   - Added to copy VCLprepare.cmd to the Group Policy Logon Folder
   - Added comment to not include path, but only include Filename for log
   on/off scripts
      - Without the two mentioned above, you see the problem where its
      pointing to Documents & Settings and admin will always be logged
out after
   - Added gpupdate /force command

Thanks to Andy, Aaron, and Brian for all your help.

On Wed, Apr 15, 2009 at 10:30 AM, Melba Lopez <milo...@gmail.com> wrote:

> Thanks for those links.  They should come in handy. :)
> As for the logon scripts, I was referring to the admin account.  When
> loging into the admin account VCL creates after a successful reservation, it
> logs me out immediately (doesn't even show desktop).  All I'm able to see is
> "saving settings".
> On Wed, Apr 15, 2009 at 10:03 AM, Aaron Peeler <aaron_pee...@ncsu.edu>wrote:
>> Your right - we're in the slow process of putting documentation at the
>> Apache wiki:
>> <http://cwiki.apache.org/VCL/>
>> Please note this is going to be the official location.
>> A rough outline of the documentation organization.
>> <http://cwiki.apache.org/VCL/documentation-organization.html>
>> With the steps to create a base XP image:
>> <http://cwiki.apache.org/VCL/creating-base-windows-xp-image.html>
>> We'll be fine tuning and stream lining these steps as we move forward.
>> Likely with the two methods in mind:
>> 1) a perl based capture_image script, that would do most if not all of the
>> step 8 ssh service is installed and configured.
>> 2) using the web interface to capture a image from a node
>> Yes there is a set of post load scripts or logon scripts that the root
>> account runs during the autologon process.
>> These are outlined in steps 13 and 14
>> Aaron
>> --On April 14, 2009 4:59:39 PM -0400 Melba Lopez <milo...@gmail.com>
>> wrote:
>>  Initially after deploying our XP image, RDP continued to refuse
>>> connection
>>> using the credentials given in the VCL web interface.  We later found
>>> this
>>> link (not mentioned in the wiki), that requires you to enable remote
>>> connection. (Perhaps this should be added to the wiki?)
>>> http://vcl.ncsu.edu/help/applications-images/creating-windows-xp-base-ima
>>> ges
>>> 3. Setup environment (most of following are recommendations just to
>>> create
>>> default configuration):
>>> - go to Start->My Computer->right click and choose "Show on Desktop"
>>> - in "System Properties" (Start->My Computer->right click->Properties)
>>> under "Remote" tab, check "Allow users to connect remotely to this
>>> computer" - IMPORTANT!
>>> After enabling this setting and redeploying, we encountered a new error
>>> where admin logs you in momentarily and quickly logs you out of the
>>> account.
>>> I tried this several times, even redoing the image to ensure I followed
>>> the steps in the wiki, but I see the same result along with some
>>> inconsistencies in between.  I've encountered 2 different scenarios more
>>> than once (with the same base image unchanged):
>>> Scenario 1:
>>> Once the VM is booting, root gets logged in and it runs its scripts.
>>>  Because of the VCLprepare.cmd script, it should automatically log off
>>> root, but in this scenario, this does not happen.  Thus, I go and log off
>>> root manually.  I then see the "admin" account in the gui.  I try to RDP
>>> with the credentials (and try the downloaded rdp file), and it will
>>> quickly log me in and out.
>>> Scenario 2:
>>> VM boots up and root logs in, runs scripts and logs out.  The gui only
>>> shows root and does not show an "admin" account.  I try to RDP with the
>>> credentials (and try the downloaded rdp file), and it will quickly log me
>>> in and out.  When I reboot the VM, the admin account now shows up in the
>>> gui.  Using the downloaded rdp file, it gives me an error connecting to
>>> the VM.  I then try using RDP manually, I'm able to login to admin, but
>>> it quickly logs me out.
>>> What scripts are being run at admin logon?  Is there a script or a
>>> setting I forgot to implement?
>>> --
>>> Melba Lopez
>>> milo...@gmail.com
>> Aaron Peeler
>> OIT Advanced Computing
>> College of Engineering-NCSU
>> 919.513.4571
>> http://vcl.ncsu.edu
> --
> Melba Lopez
> milo...@gmail.com

Melba Lopez

Reply via email to