This is my first install of VCL, and everything has gone 
smoothly so far. I've now reached my first serious block.

When trying to reload images through the web interface, I get 
the following in my vcld logs. I'm wondering if one of the 
underlying Perl modules is causing the error but for the life 
of me I can't determine where to start looking to see if I can 
solve the problem. 

Here are the relevant lines from vcld.log

2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:reservation_being_processed
(10269)|computerloadlog 'begin' entry does NOT exist for 
reservation 4
2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:reservation_being_processed
(10321)|reservation is NOT currently being processed
2009-06-24 
22:17:49|12930|5:4|reload|vcld:main(276)|reservation 4 is NOT 
already being processed
2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:get_request_info(5872)|non-
NCSU user affiliation found: Local
2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:get_management_node_info(72
66)|management node info retrieved from database for 
soeblade13
2009-06-24 22:17:49|12930|5:4|reload|vcld:main(281)|retrieved 
request information from database
2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:get_management_node_info(72
66)|management node info retrieved from database for 
soeblade13
2009-06-24 
22:17:49|12930|5:4|reload|DataStructure.pm:is_parent_reservati
on(854)|returning true: parent reservation ID for this 
request: 4
2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:update_request_state(2302)|
request 5 state updated to: pending, laststate to: reload
2009-06-24 
22:17:49|12930|5:4|reload|utils.pm:insertloadlog(5224)|inserte
d computer=1, begin, beginning to process, state is reload
2009-06-24 
22:17:49|12930|5:4|reload|vcld:make_new_child(501)|request 
will be processed by new.pm
2009-06-24 
22:17:49|12930|5:4|reload|vcld:make_new_child(509)|loaded 
VCL::new module
2009-06-24 
22:17:49|12967|5:4|reload|vcld:make_new_child(582)|vcld 
environment variable set to 0 for this process
2009-06-24 
22:17:49|12967|5:4|reload|Module.pm:new(132)|constructor 
called, class=VCL::new
2009-06-24 
22:17:49|12967|5:4|reload|Module.pm:new(154)|VCL::new object 
created
2009-06-24 
22:17:49|12930|5:4|reload|vcld:make_new_child(566)|current 
number of forked kids: 1
2009-06-24 
22:17:49|12967|5:4|reload|State.pm:initialize(85)|obtained a 
database handle for this state process, stored as $ENV{dbh}
2009-06-24 
22:17:49|12967|5:4|reload|State.pm:check_image_os(809)|no 
corrections need to be made, not an imaging request, returning 
1
2009-06-24 
22:17:49|12967|5:4|reload|DataStructure.pm:is_parent_reservati
on(854)|returning true: parent reservation ID for this 
request: 4
2009-06-24 
22:17:49|12967|5:4|reload|utils.pm:rename_vcld_process(8392)|r
eservation count: 1
2009-06-24 
22:17:49|12967|5:4|reload|utils.pm:rename_vcld_process(8411)|P
ARENTIMAGE: 1
2009-06-24 
22:17:49|12967|5:4|reload|utils.pm:rename_vcld_process(8412)|S
UBIMAGE: 0
2009-06-24 
22:17:49|12967|5:4|reload|utils.pm:rename_vcld_process(8430)|r
enamed process to 'vcld VCL::new 5:4 reload'
2009-06-24 
22:17:49|12967|5:4|reload|DataStructure.pm:is_parent_reservati
on(854)|returning true: parent reservation ID for this 
request: 4
2009-06-24 
22:17:49|12967|5:4|reload|DataStructure.pm:is_parent_reservati
on(854)|returning true: parent reservation ID for this 
request: 4
2009-06-24 
22:17:49|12967|5:4|reload|State.pm:initialize(121)|attempting 
to load provisioning module: VCL::Module::Provisioning::esx

|12967|5:4|reload| ---- WARNING ----
|12967|5:4|reload| 2009-06-24 
22:17:49|12967|5:4|reload|State.pm:initialize(124)|VCL::Module
::Provisioning::esx module could not be loaded, returning 0
|12967|5:4|reload| ( 0) utils.pm, notify (line: 719)
|12967|5:4|reload| (-1) State.pm, initialize (line: 124)
|12967|5:4|reload| (-2) Module.pm, new (line: 157)
|12967|5:4|reload| (-3) vcld, make_new_child (line: 590)
|12967|5:4|reload| (-4) vcld, main (line: 341)


What could be causing VCL::Module::Provisioning::esx to not 
load? I've checked and the VMWare-VI-Perl tools have been 
properly installed.

Thanks in advance for any assistance you all can provide.

- Cliff

Reply via email to