On 02/02/08 11:35, Magnus Andersson wrote:
> Klaus Schmidinger wrote:
>> On 02/01/08 19:17, Magnus Andersson wrote:
>>   
>>> Hello!
>>>
>>> I have problems with channels that uses high bitrate on Thor 1W. A few
>>> channels uses between 10-11 Mbit/s mpeg2 and if I use tv-out from FF
>>> card vdr 1.5.14 the picture glitches and the remote response becomes
>>> really slow. It can take 10 seconds or more to change channel. There are
>>> no problems if I use xineliboutput and vdr 1.5.14 or channels with low
>>> bitrate. VDR 1.4.7 is ok with both xinliboutput plugin and tv-out from
>>> FF card so my question is how to log this? I start vdr with option -l 3
>>> but there is nothing in the log.
>>>     
>>
>> Please post the channel definitions of some of these channels.
>>
>> Klaus
>>
>> _______________________________________________
>> vdr mailing list
>> vdr@linuxtv.org
>> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
>>   
> 
> 24;Telenor:12303:vC34M0O0S0:S1.0W:27799:523:684=sve:576:B00:3012:70:16:0
> SVT2 
> ¬stNytt;Telenor:12303:vC34M0O0S0:S1.0W:27799:512:640=sve;641=sve:576:B00:3009:70:16:0
> 24 
> ¬stNytt;Telenor:12303:vC34M0O0S0:S1.0W:27799:523:684=sve:576:B00:3020:70:16:0
> 
> The problem is not always permanent but here a good way to reproduce the
> problem. Restart vdr on BBC World (FTA) channel on Thor 1W and configure
> vdr to start at last channel.
> 
> BBC World;Telenor:11325:hC78M0O0S0:S1.0W:24500:513:644=eng:577:1:1001:70:25:0
> 
> 
> When BBC world has started tune one of the high bitrate channels and you
> will see the problem.

Those Telenor channels are encrypted, so I'm afraid I can't test them.

However, this may also be the reason for your problem. When VDR first switches
to an encrypted channel, it always does so in Transfer-Mode, so that it can
check whether the TS packets get decrypted. Once it knows that a channel can be
decrypted, it switches to it in direct live mode if you switch to it again.

While in Transfer-Mode, the high data rate stream is read from the FF card
and sent back to it for replay. I assume this is too much load for the FF card.

Try switching to the same channel again after some 15 seconds. Does it show
up ok then?

Klaus

_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to