On Thu, 2008-08-14 at 11:25 +0200, Thomas Hilber wrote:

Good heavens, this is all getting rather heavyweight :)

> oh - a very interesting fact.
> that's different to mine (see my output of top below). Xorg takes only 0.7%(!)
> CPU on my system. Are there some special patches in ubuntu that causes
> this?

1% CPU is about what I would expect for xv usage - after all the whole
point is for the app to write directly to video memory with minimal

A skirt around the problem with Google reveals very little - only a
string of users complaining that their silly 3D desktop is slow /
unstable (who would have thought? :)

> This appears be the root cause of our problem!
> Does the Xserver poll for some resources not available or something?
> A value of 40% CPU is way too much. The only process consuming some CPU
> power should be 'vdr' whilst decoding. Most other processes don't have
> to do much all over the time.

It should be said that Xorg is idle when just showing a desktop. It's
only when video is played that usage shoots up.

> We must dig deeper into that '40% Xserver-CPU' phenomenon! 
> DISPLAY environment variable is set to DISPLAY=:0 ?

Yes. I tried also using mplayer -vo xv /video/blahhhh/12313131/001.vdr
and that also generated the same amount of load in Xorg. However, since
the PC (Dell Optiplex) has onboard Intel 810 VGA, I removed the radeon
and tried it. The same mplayer test yielded only 6% Xorg CPU. Still
higher than I would expect, but it was an 800x600 VGA display. 

Even deleting the xorg.conf and letting the radeon driver choose 'best
defaults' I get the 40% CPU load.

> You see Xorg is almost not noticable on my system!
> Can you strace the Xserver? Maybe you can try Debian experimental packages
> like I do? Don't the run on Ubuntu as well?

Well, the Debian experimental packages installed OK, but refused to

/usr/bin/X11/X: symbol lookup
error: /usr/lib/xorg/modules/drivers//radeon_drv.so: undefined symbol:
giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  unexpected signal 2.

(yes, the radeon driver package was upgraded to the experimental one :)

and now I am unable to reinstall the ubuntu xorg due to circular
dependencies and very strange package behaviour (see [1]), so I've given
up on this installation. A shame, since I'd done well and not installed
anything into /usr/local this time :)

> If it would help you I can offer you to make a copy of my entire development
> system (about 800MB as compressed tar image). 

At this stage that sounds like a good idea. I originally intended to
install lenny but the Debian netinst + 'testing2' iso claimed there was
no hard disk on the PC (I had the same experience earlier that day with
a server at work), so I tried Ubuntu which installed perfectly. 

Are you suggesting to provide a tarball that I can 'tar xzf' into a
freshly-formatted root partition (then run grub) ?


[1] [EMAIL PROTECTED]:~# apt-get install xserver-xorg xserver-xorg-core
The following packages have unmet dependencies.
  xserver-xorg: Depends: x11-xkb-utils but it is not going to be
                  PreDepends: x11-common (>= 1:7.3+3) but it is not
going to be installed
  xserver-xorg-core: Depends: libfontenc1 but it is not going to be
                     Depends: libxau6 but it is not going to be
                     Depends: libxdmcp6 but it is not going to be
                     Depends: libxfont1 (>= 1:1.2.9) but it is not going
to be installed
                     Depends: x11-common (>= 1:7.0.0) but it is not
going to be installed

All the Depends: packages are /already/ installed and meet those version

vdr mailing list

Reply via email to