Thanks Gerald and Darren

So I tried to build xine-lib-1.2 the debian way...

- modified changelog
- modified debian/rules Makefile with my configure options
- tried to meet all dependencies of the control file

But there are various dependencies I simply can't meet because
they would conflict with files installed by svn ffmpeg:

libavcodec-dev (>= 0.cvs20080206) | libavcodeccvs-dev,
libavformat-dev (>= 0.cvs20080206) | libavformatcvs-dev,
libpostproc-dev (>= 0.cvs20080206) | libpostproccvs-dev,
libavutil-dev (>= 0.cvs20080206) | libavutilcvs-dev,

So I removed those from the control file

Now I can compile it till right to the end of dh_installdeb
but then it fails because of the missing dependency
libavutil-dev I guess:

dpkg-shlibdeps: Fehlschlag: Keine Abhängigkeitsinformationen für \
/usr/lib/ (verwendet von debian/libxine2/usr/lib/xine/ \
plugins /2.0/ gefunden.

Anyway - here's what I get in the parent directory:

/usr/src$ ls -la xine-lib-1.2_1.2.0~hg-1*
-rw-r--r-- 1 se src    1387 2009-01-25 16:18 xine-lib-1.2_1.2.0~hg-1.dsc
-rw-r--r-- 1 se src 1518029 2009-01-25 16:24
-rw-r--r-- 1 se src 6537395 2009-01-25 16:18 xine-lib-1.2_1.2.0~hg-1.tar.gz

As you can see the dep archive is missing

How to solve this one? Like I said I can't install any of the libav*-dev 

Teste jetzt den neuen, verbesserten Windows Live Messenger!
vdr mailing list

Reply via email to