Op Wo, 4 februari, 2009 10:16, schreef Morfsta:
> Hi,


> Due to an attempt on OS upgrade and thus kernel upgrade I'm grudgingly
> (it worked for me for months with no issues so why would I want to
> change it for now?) trying to make the transition from multiproto to
> S2API. I have two DVB-T cards and a NOVA-S2-HD (HVR4000 lite). I have
> downloaded a vanilla vdr-1.7.0 applied the h264 patch and the s2api
> patch and install S2API from Steven Toth's mercurial repository.

You might want to try Igor's repo
http://mercurial.intuxication.org/hg/s2-liplianin)  since Steve's hasn't
been updated for over 3 months. This however won't fix your problem perse.

> On booting the kernel loads all the modules and I see the various
> frontends and when I start VDR it loads all of the relevant firmware
> okay. When I start VDR it won't show any of the FTA channels on DVB-T
> or DVB-S (not even tried S2!) and all I get is "Channel Not
> Available". I wish VDR were more descriptive in why the channels are
> not available! :-)

Did you install mine S2API patch from 7-10 for VDR 1.7.0? Because this is
the latest version and this has been tested with DVB-T, DVB-S, DVB-S2 and
DVB-C. And with succes! ;)

BTW, you might want to increase the logging for VDR or check the logfiles
in /var/log what VDR has thrown out (Ubuntu uses /var/log/user.log for
instance). My best guess is an frontend timeout error. This means that a
timeout (duh!) occured when tuning to the selected channel. This can mean
a reception problem (not likely, but good to point out) or a problem in
your channels.conf.

> Apologies if this has been asked before, but is there anything I'm
> missing? Is the problem that I took my channels.conf from my
> multiproto VDR and something has now changed in the format?

The Multiproto channels.conf should be interchangeable with S2API. But
*some* modulation types didn't exist in S2API when I wrote the patches and
you need to check this for yourself. You need to check the settings (Red
button to edit in the TV Channels overview) and see if they are indeed
correct and change them accordinly. My best guess, is that the modulation
types are wrong.

> It would be good to get this working as my old OS is now messy and
> really needs a clean build with a shiny new kernel and I can't patch
> up to date multiproto with the old HVR4000 patches (a few FAILS which
> I guess I could fix, but might take some time as they don't look that
> trivial) and an older version of multiproto from HG doesn't compile on
> the new kernel!

Best to say, multiproto is not needed to get it al working. I've got the
same kind of config as you ( NOVA-HD-S2 and a Gigabyte USB stick for
DVB-T) and it works very good with S2API.

> Can anyone point me in the right direction on what might be going on?

See the above ;)

> Thanks


Niels Wagenaar

vdr mailing list

Reply via email to