On 05/02/2013 10:09 AM, Antoni Segura Puimedon wrote:

----- Original Message -----
From: "Vinzenz Feenstra" <vfeen...@redhat.com>
To: "Mark Wu" <wu...@linux.vnet.ibm.com>
Cc: vdsm-devel@lists.fedorahosted.org
Sent: Thursday, May 2, 2013 9:54:09 AM
Subject: Re: [vdsm] Is vdsm still maintained for Fedora 17?

On 05/02/2013 09:31 AM, Mark Wu wrote:
On 05/02/2013 01:30 PM, Vinzenz Feenstra wrote:
On 05/02/2013 05:22 AM, Mark Wu wrote:
Hi Dan,

Since the repo of virt-preview for fedora17 is not maintained after
fedora 18 was released,  it could be difficult to install the
packages vdsm master branch requires on fedora17.
Currently i cannot install VDSM on Fedora 18 without packages from
koji or enabling rawhide, when trying to install vdsm/master.

So do we still maintain vdsm for fedora17?  Do we need consider if
the patch to upstream will cause break on fedora17?
I wish we would do, but then again do we want to limit ourselves so
that we cannot use some things we would use otherwise?
For me, it's not very meaningful to support master branch on old
distro releases,  especially for old fedora.
F18 is not an old distro release and it's not working either with f18
because of required versions ...
Could you please post which are these requirements that are not satisfied
even by updates-testing?
--> Processing Dependency: libvirt >= 1.0.2-1 for package: vdsm-4.10.3-0.369.git62ee4ea.fc18.x86_64
--> Finished Dependency Resolution
Error: Package: vdsm-4.10.3-0.369.git62ee4ea.fc18.x86_64 (/vdsm-4.10.3-0.369.git62ee4ea.fc18.x86_64)
           Requires: libvirt >= 1.0.2-1
           Installed: libvirt-0.10.2.3-1.fc18.x86_64 (installed)
               libvirt = 0.10.2.3-1.fc18
           Available: libvirt-0.10.2.2-3.fc18.x86_64 (fedora)
               libvirt = 0.10.2.2-3.fc18
           Available: libvirt-0.10.2.4-1.fc18.x86_64 (updates)
               libvirt = 0.10.2.4-1.fc18
Error: Package: vdsm-4.10.3-0.369.git62ee4ea.fc18.x86_64 (/vdsm-4.10.3-0.369.git62ee4ea.fc18.x86_64)
           Requires: libvirt >= 1.0.2-1
           Removing: libvirt-0.10.2.3-1.fc18.x86_64 (installed)
               libvirt = 0.10.2.3-1.fc18
           Updated By: libvirt-0.10.2.4-1.fc18.x86_64 (updates)
               libvirt = 0.10.2.4-1.fc18
           Available: libvirt-0.10.2.2-3.fc18.x86_64 (fedora)
               libvirt = 0.10.2.2-3.fc18
 You could try using --skip-broken to work around the problem

Checking: https://admin.fedoraproject.org/updates/libvirt

FEDORA-2013-4691 libvirt-0.10.2.4-1.fc18 Fedora 18 stable
crobinso 2013-04-01 22:04:31

0.10.4-1 is the latest and that's what is available. 1.x is not available on f18.

I have been checking it on koji and  libvirt >= 1.0.2-1 is currently satisfiable with libvirt-1.0.4-1.fc19 which obviously is F19.


Regards,


Thanks.
Mark

_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel


        

--
Regards,

Vinzenz Feenstra | Senior Software Engineer
RedHat Engineering Virtualization R & D
Phone: +420 532 294 625
IRC: vfeenstr or evilissimo

Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com

_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel



-- 
Regards,

Vinzenz Feenstra | Senior Software Engineer
RedHat Engineering Virtualization R & D
Phone: +420 532 294 625
IRC: vfeenstr or evilissimo

Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com
_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to