On Monday, August 09, 2004, at 04:37PM, Dave Greenwood <[EMAIL PROTECTED]> wrote:

>I then did
>  mmk clean
>  mmk
>  mmk install
>However, I still get the "Can't locate auto/Net/DNS/typesbyname.al"
>> >So - what's a ".al" file?  It's not in the module package so what
>> >creates it?
>> It's part of a module that's been split off for more efficient
>> loading by the autoloader.  That should get set up automatically
>> during the build and install.  You might try explicitly making the
>> pm_to_blib target and then reinstalling.
>> $ mms pm_to_blib
>> $ mms install
>I tried the "mms pm_to_blib" (even with /force and /from_source) and
>"mms install" but I still get the error.  I can't find any reference
>in the descrip.mms files to any ".al" files.

I tried installing, which I had not done before.  I did not get any .al files either.  
But I also don't get the error you speak of when running the tests that come with the 
package.  Do you have a small reproducer derived from the script that is giving you 

BTW, you can find out more about what the .al files are about by doing

$ perldoc Autoloader

However, I'm now thinking that is a red herring since I don't see anything in Net::DNS 
that looks like it is set up to be autoloaded.  There may be some other problem 
loading the function and then it falls back to the autoloader for some reason.  What 
do you get from a really simple use of the function, like this:

$ perl -e "use Net::DNS; print Net::DNS::typesbyname('CERT');"

Reply via email to