I think you'll find the problem is with the vmware server not passing through the vlan tags (especially since its windows, ive never had much luck with 801q and microsoft). i dont think that is supported. everything looks correct except that part. do you have a desktop machine you can run the livecd on with an identical config and see if it works? that will at least isolate it down to vmware or vyatta. I'm pretty sure you'll find its the former.

------------------
Aubrey Wells
Senior Engineer
Shelton | Johns Technology Group
A Vyatta Ready Partner
www.sheltonjohns.com




On Nov 21, 2007, at 7:43 AM, youssef salameddine wrote:

Hi,

Thank you for you answer

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
These is the config of my switch1, the second switch is a copy of the first and i used it for redundancy:

interface GigabitEthernet0/1
description To_ESX1_ServiceConsole_VMKNIC # I use this interface for service console of My ESX1 The vlan 101 is used for service console and the vlan 102 is used for VMotion#
 switchport access vlan 101
 switchport trunk allowed vlan 101,102
 switchport mode trunk
 switchport nonegotiate
 speed 1000
!
interface GigabitEthernet0/2
description To VM_of_esx1_103_104 # I use this interface for my VMs i have some virtual machine in the vlan 103 and others on the Vlan 104#
 switchport access vlan 103
 switchport trunk allowed vlan 101,103-115
 switchport mode trunk
 switchport nonegotiate
 speed 1000

interface GigabitEthernet0/21
 description VM_VLAN103 #Allow Access to VMs on the Vlan 103#
 switchport access vlan 103
 switchport mode access
 switchport nonegotiate
!
interface GigabitEthernet0/24
 description VM_VLAN104 #Allow Access to VMs on the Vlan 104#
 switchport access vlan 104
 switchport mode access
 switchport nonegotiate
 speed 1000

!
interface GigabitEthernet0/43
 description To_vyatta
 switchport access vlan 101
 switchport trunk allowed vlan 101-200
 switchport mode trunk
 no cdp enable
!
interface GigabitEthernet0/44
description admin_switch101 #I use this interface for remote access to Switch 1#
 switchport access vlan 101
 switchport trunk allowed vlan 101,103-115
 switchport mode access
 switchport nonegotiate
!

interface GigabitEthernet0/48
 description To_SW2 # The uplink used to link the two cisco 2950#
 switchport access vlan 101
 switchport trunk allowed vlan 101,103-115
 switchport mode trunk
 media-type rj45
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan101
# This is the interface that i use for administration of my Switch1#
 ip address 10.30.101.1 255.255.255.0
 no ip route-cache
!

ip default-gateway 10.30.101.254 # This is the ip address of eth0 of my vyatta #
ip http server
!
control-plane
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
My vyatta is a VM running within VMware Server installed in a separtae machine with W2K3. The address of the physical interface is 10.30.101.253(I use this interface to remotely access this machine using RDP).

Eth0 of my vyatta is bridged to this interface and its address is: 10.30.101.254
the configuration of my vyatta is:
ethernet eth0{
description "vers switch1"
hw-id: ----:73
address 10.30.101.254 {prefix-length:24}
vif 103{
description:"Vlan 103"
address 10.30.103.254 {prefix-length:24}
}

vif 104{
description:"Vlan 104"
address 10.30.104.254 {prefix-length:24}
}
}
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Note that Virtual machines within Vlan 103 can communicate.and Virtual machines whtin Vlan 104 can communicate. But VMs of vlan 103 can't communicate with vms of vlan 104, and VMs of vlan 104 can't communicate with vms of vlan 103. VMs can't communicate withe the default gateway which is the vif of vyatta: for example my VM 10.30.103.10 can't communicate with 10.30.103.254 which is its Default Gateway.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
I hope that it was clear
Thank you For your Help








2007/11/21, Aubrey Wells <[EMAIL PROTECTED]>:
Can you post your (sanitized) config?



------------------
Aubrey Wells
Senior Engineer
Shelton | Johns Technology Group
A Vyatta Ready Partner
www.sheltonjohns.com




On Nov 20, 2007, at 7:23 PM, youssef salameddine wrote:

Thanks a lot for your answer,

Yes, I did so, But my hosts can't ping the default gateway.
IE: in vlan 103: the host 192.168.103.3 can't ping the vif 192.168.103.1. note that my hosts are virtual machines whithin an esx server. The hosts are connected to a Virtual switch wich Tag data of VMs with the appropriate Vlan. And for example av VM in Vlan 103 can communicate with both a VM or a physical computer whitin the same Vlan, but it can't ping The Vif 103.

Thank you For you help



2007/11/21, Aubrey Wells <[EMAIL PROTECTED] >:
you'll need to assign an ip to each vif that is in the same subnet as your hosts in each vlan, and then set that ip (the one on the vif) as the default gateway of the clients.

ie:

vlan 101
subnet 192.168.101.0 /24
vyatta ip on eth0.101 192.168.101.1 /24
host ips 192.168.101.2-254 /24 gw 192.168.101.1

vlan 102
subnet 192.168.102.0 /24
vyatta ip on eth0.102 192.168.102.1 /24
host ip 192.168.102.2-254 /24 gw 192.168.102.1

vlan 103
subnet 192.168.103.0 /24
vyatta ip on eth0.103 192.168.103.1 /24
host ip 192.168.103.2-254 /24 gw 192.168.103.1

make sense?

------------------
Aubrey Wells
Senior Engineer
Shelton | Johns Technology Group
A Vyatta Ready Partner
www.sheltonjohns.com




On Nov 20, 2007, at 6:15 PM, youssef salameddine wrote:

Hi,

I have Two cisco Switchs 2950 sw1 & sw2 with a vtp link ( 802.1q trunk). sw1 is the vtp server and sw2 is the vtp client. The two switchs have 3 vlans: Vlan101, Vlan 102 and vlan 103 and the vlans can't communicate because there is no routing between them. I decide to use vyatta to implement routing inter-vlans. So I have a Vyatta VM that i linked to a port of sw1 and i configured this port as trunk in the sw1 side (switchport mode trunk). I also create 3 vif (sub interface of my vyatta interface eth0), so now i have eth0.vif101, eth0.vif102 and eth0.vif103. with this configuration machines on a vlan can't communicate with machines on an other vlan: what do i have to do on my vyatta to activate intervlan routing.

Thanks for your help

--

_______________________________________________
Vyatta-users mailing list
Vyatta-users@mailman.vyatta.com
http://mailman.vyatta.com/mailman/listinfo/vyatta-users




--

_______________________________________________
Vyatta-users mailing list
Vyatta-users@mailman.vyatta.com
http://mailman.vyatta.com/mailman/listinfo/vyatta-users




--

_______________________________________________
Vyatta-users mailing list
Vyatta-users@mailman.vyatta.com
http://mailman.vyatta.com/mailman/listinfo/vyatta-users

_______________________________________________
Vyatta-users mailing list
Vyatta-users@mailman.vyatta.com
http://mailman.vyatta.com/mailman/listinfo/vyatta-users

Reply via email to