Ideally it should be USE(THE_SPECIFIC_FRAMEWORK_IN_QUESTION). I would guess 
that much of PLATFORM(MAC) that is valid for both Mac and iOS should actually 
be USE(FOUNDATION). PLATFORM really shouldn't be used for things other than 
terminal platform names. USE(COCOA) would be an ok stopgap if sorting down to 
more specific conditionals delays this cleanup too much.

Regards,
Maciej

On Jan 11, 2014, at 2:47 PM, Darin Adler <da...@apple.com> wrote:

> Hi folks.
> 
> There is a lot of WebKit code that needs to be on for “the Mac and iOS 
> ports”. Some of it is guarded be conditionals with a higher level concept. 
> But most of it, now this is guarded by PLATFORM(MAC). I think that’s really 
> confusing and we need to rename PLATFORM(MAC) to something else. Perhaps 
> PLATFORM(COCOA)? Or maybe it’s SOMETHING_ELSE(COCOA)?
> 
> Then we can use PLATFORM(MAC) for “the Mac port” rather than PLATFORM(MAC) && 
> !PLATFORM(IOS).
> 
> Later we can start renaming file names as well, but for now I just want to 
> fix the conditionals to be more readable. And of course, it’s even better in 
> cases where we can move away from platform conditionals to more logical 
> conditionals such as USE(CF) or USE(APPKIT).
> 
> So, is PLATFORM(COCOA) an acceptable new name for what is currently named 
> PLATFORM(MAC)? If not, what’s a better choice?
> 
> Lets do this soon. It’s hard for me to remember that in WebKit, PLATFORM(MAC) 
> means “the Mac and iOS ports”.
> 
> — Darin
> _______________________________________________
> webkit-dev mailing list
> webkit-dev@lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev

_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to