No luck so far! I have attempted to follow and adapt Matthew Wall's 
detailed directions, without success. I've also tried Vince's suggestion of 
using a Pi as a separate DNS server. And I tried George Nincehelser's IPWX 
as well (on a Debian laptop instead of a Pi). Along the way, I began to 
suspect that my bridge wasn't working as it should. All I knew for sure was 
that I never got any human-readable data from it, and that the sensor 
status light would illuminate whenever the bridge was powered, the network 
status light would cycle on, then off again about once every minute. Syslog 
on the laptop confirmed that the bridge was connecting and disconnecting 
repeatedly.

As of today, neither status light is illuminating, and I suspect it's now a 
bricked bridge. Is there anything I can attempt to revive it, or should I 
start looking for another?

Meanwhile, I've encountered another issue, that I think is independent of 
the hardware issues. Installation of the Interceptor appeared to be 
successful, but I am unable to run the driver directly, following the 
directions in the readme file. This command:

PYTHONPATH=bin python bin/user/interceptor.py --help

produces this error:

python: can't open file 'bin/user/interceptor.py': [Errno 2] No such file or
directory

Python 2.7 and 3.4 are both installed on the laptop. "python" is linked to 
2.7 in /usr/bin/.

Thanks for any guidance anyone is willing to provide!



On Wednesday, February 28, 2018 at 12:06:42 PM UTC-5, RobbH wrote:
>
> This is more a Linux question than a Weewx question, but it is necessary 
> to get Weewx working the way I want it to. This is a networking issue 
> unlike any I've dealt with, so I hope someone with greater knowledge will 
> be willing to share it.
>
> My main router, a Netgear R7000, does not provide the sort of DNS 
> flexibility I need to route the bridge's calls to hubapi.myacurite.com to 
> the computer running Weewx. I could install dd-wrt firmware and get that 
> capability, but that would reduce the router's wireless range, so I'm 
> reluctant to do that.
>
> My plan was to add a second ethernet port to the Weewx computer, and 
> "share the internet connection" through that port. I assumed that I could 
> then add this line to the hosts file on that computer:
>
> 127.0.0.1 hubapi.myacurite.com
>
> and that would solve the problem. But it doesn't seem to work as expected. 
> I can plug a laptop into the shared port and browse the web, But requests 
> from the laptop are not filtered through the hosts file. I've also tried 
> setting up dnsmasq, but with the same result. Both the hosts file and 
> dnsmasq work as they should for requests from a browser on the same 
> computer, but not for the laptop plugged into the shared port.
>
> (Just for what it's worth, I've tested this approach on my main desktop, 
> running Mint 17.3 (X86_64). The Weewx computer is running Debian Jessie (32 
> bit). I realize that a working solution on the Mint desktop may not 
> transfer perfectly to the Debian box, but it should at least get me in the 
> ballpark before I start messing with the Weewx machine.)
>
> At this point, I'm completely stymied. I suspect there's something very 
> basic that I'm overlooking. I've been using Linux more than ten years now, 
> but I've learned it piecemeal, just picking up bits of information as 
> needed. That sometimes catches up with me, and my guess is that this is one 
> of those times. If anyone can help me get started on the right path, I'll 
> be grateful.
>
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to