If the "Command not found" is not from the sed command itself, it might be caused by the arguments to the sed command.  However, it cannot be determined what the cause and solution is unless the script and line with the sed command is identified.

If you can provide information on the computing system, perhaps someone will encounter the same problem or be able to reproduce it.

Linux version (example, Ubuntu 18.04.3):

sed version (example, output of command 'sed --version' [1]):

tcsh version (example, output of command 'dpkg -l tcsh' [2]):

csh version (example, output of command 'dpkg -l csh' [3]):

WIEN2k version (example, output of command 'cat WIEN2k_VERSION' [4]):

Did you just check 'sed' in your user account?  Since you are doing parallel, did you also check if sed works when you login to your nodes (which appears to be 'ssh localhost' in your case)?  If you use root, su, or sudo for running WIEN2k, I suggest use of the user account instead and not those unless your experienced with that as those administrative environments can sometimes behave differently with unexpected consequences [5].

[1] http://manpages.ubuntu.com/manpages/trusty/man1/sed.1.html
[2] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg18018.html [3] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg16030.html [4] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg18956.html [5] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg10594.html

On 11/27/2019 4:32 AM, Peeyush kumar kamlesh wrote:
Thank you all !
The problem is solved by running the same command with using additional flag "-NI". Dear Gavin Sir, 'sed' is already installed, still it showed *"sed: Command not found".

On Tue, Nov 26, 2019 at 5:53 AM Peeyush kumar kamlesh <peeyush.physik....@gmail.com <mailto:peeyush.physik....@gmail.com>> wrote:

    I am using single node of four cores. Mu machine file is below:

    On Mon, Nov 25, 2019 at 10:06 PM Peeyush kumar kamlesh
    <mailto:peeyush.physik....@gmail.com>> wrote:

        Hello Wien2k user,
        I am running scf cycle with hf potential. When I run the
        command "run_lapw -hf -p", then after successful completion of
        7 cycles, I found error in cycle 8. In terminal it is
        represented as follows:
        in cycle 8    ETEST: .0004919150000000   CTEST: .0035867
        hup: Command not found.
         LAPW0 END
         LAPW0 END
         LAPW1 END
         LAPW1 END
         LAPW1 END
         LAPW1 END
        sed: Command not found.
        LAPW2 - Error. Check file lapw2.error
        cp: cannot stat '.in.tmp': No such file or directory

        >   stop error

        When I checked lapw2.error file I found following details:
        'LAPW2' - can't open unit: 10
         'LAPW2' -        filename: /case.vector
         'LAPW2' -          status: unknown      form: unformatted
        **  testerror: Error in Parallel LAPW2

        I also tried to search and understand the previous threads,
        but I was unable to do so. Kindly suggest me why this error is
        appearing and how can it be resolved?

        Thanks and Regards
        Peeyush Kumar Kamlesh

Wien mailing list

Reply via email to