On Wed, Jan 24, 2007 at 06:14:24PM +0100, Ulf Lamping wrote:

> The current way we handle Win32 DLL export of symbols is a bit odd in 
> my eyes.

I agree ;)

> This way you'll simply add WS_SYMBOL_IMEXPORT to the header file to 
> im/export a symbol, e.g.:
> 
> WS_SYMBOL_IMEXPORT int eth_stdio_open (...

> Any objections against this (in my eyes cleaner) solution?

Sounds good to me.  Would we export all symbols or still only certain 
ones?

> P.S: A better name than WS_SYMBOL_IMEXPORT would be nice, any ideas? 
> Or is it ok?

What does the IM stand for? 


Steve

_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev

Reply via email to