On Jul 23, 2011, at 12:48 PM, Mark Dootson wrote:

> Hi,
> To build all current wxWidgets, either stable or development, you need to use 
> SDK 10.6 or below I think.
> The code pasted below is untested but should probably work using 
> Alien::wxWidgets from SVN to get you a 2.9.2 build
> perl Build.PL --wxWidgets-extraflags=" 
> --with-macosx-sdk=/Developer/SDKs/MacOSX10.6.sdk 
> --with-macosx-version-min=10.5" --wxWidgets-build='yes' 
> --wxWidgets-source='tar.bz2' --wxWidgets-version=2.9.2

There is no "or below" on Lion; only the 10.6 and 10.7 SDKs are available and 
supported; copying other SDKs from earlier versions of XCode doesn't work.

John Ralls

Reply via email to