A fresh install of Mint stable after purging *x2go* libnx* nx* results in:

The following packages have unmet dependencies:
x2goserver : Depends: x2goserver-x2goagent (>= 4.1.0.0-0~1517~ubuntu16.04.1) but it is not going to be installed Depends: x2goserver-x2goagent (< 4.1.0.0-0~1517~ubuntu16.04.1.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

     Unlike Ubuntu, I got the same thing with Nightly Builds on Mint:

apt install x2goserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
x2goserver : Depends: x2goserver-x2goagent (< 4.1.0.1-0~1606~ubuntu16.04.1.1~) but it is not going to be installed Depends: x2goserver-x2goagent (>= 4.1.0.1-0~1606~ubuntu16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

     I have no held packages;

 # apt-mark showhold

     Shows nothing.

 dpkg -l | grep ^..r

     Also shows nothing, so there are neither held nor broken packages.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
 Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
   Knowledgeable human assistance, not telephone trees or script readers.
 See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

On Fri, 2 Mar 2018, Robert Dinse wrote:

Date: Fri, 2 Mar 2018 16:49:42 -0800 (PST)
From: Robert Dinse <nan...@eskimo.com>
To: Mihai Moldovan <io...@ionic.de>
Cc: x2go-user@lists.x2go.org
Subject: Re: [X2Go-User] LinuxMint 18.3 upgrade fails


    Trying to install x2go stable x2goserver on Ubuntu 17.10 I am getting:

The following packages have unmet dependencies:
x2goserver : Depends: x2goserver-x2goagent (>= 4.1.0.0-0~1517~ubuntu17.10.1) but it is not going to be installed Depends: x2goserver-x2goagent (< 4.1.0.0-0~1517~ubuntu17.10.1.1~) but it is not going to be installed

    ... However the Nightly Builds installed and functions fine.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
  Knowledgeable human assistance, not telephone trees or script readers.
See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

On Fri, 2 Mar 2018, Mihai Moldovan wrote:

Date: Fri, 2 Mar 2018 23:25:51 +0100
From: Mihai Moldovan <io...@ionic.de>
To: x2go-user@lists.x2go.org
Subject: Re: [X2Go-User] LinuxMint 18.3 upgrade fails

* On 03/02/2018 12:18 PM, Stefan Baur wrote:
-After the most resent update:

x2goagent : Depends: nxagent (< 2:3.5.0.33-0~710~ubuntu16.04.1.1)

-however,
nxagent is already the newest version (2:3.5.99.14-0~816~ubuntu16.04.1).

Please wait until all the builds have completed, then try again.

Was caused by x2goserver release builds not being ready yet.

All supported platforms should now feature updated x2goserver packages.

The dependency problems should be gone by now.



Mihai



_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-user
_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-user

Reply via email to