Since this seems to be a German application, can we assume you are located in Germany and speak German?
Yes, that's correct.

apt policy nxagent
results in
Installed: 2: Candidate: 2:
So, the current version of nx-libs is installed.

Best regards,
Kevin On 16 May 2018 21:37, Ulrich Sibiller <> wrote:
On Wed, May 16, 2018 at 9:06 PM, Kevin Kremer <> wrote:
Thanks all for your answers.

You should definitely use open-jdk instead of Oracle jdk

I tried running OpenJDK but the java application seems to start only when
using Oracle Java. I checked the developer's documentation which states
Oracle Java as a requirement.


Try with JOSM

I tested which runs without any problems.

Are you using the most current version of nx-libs (3.5.99-16)? What's the
name of the app? Is it using OpenGL? And have you tried OpenJDK instead of
Oracle's java?

We bought this application (called heimbas) for accounting and
documentation. I will try to contact the developers again, even though I
fear they will just refer to the RDP connection on our old windows machine
where the app is running fine.

The vendor states it runs on Linux. So I don't see why he should point
you to using Windows.

As far as I know, it does not use any additional libs like OpenGL.

Can you tell me how to check the version of nx-libs? I simply installed
x2goserver and x2goserver-xsession which apparently do not install an
additional nx-libs package (apt policy nx-libs does not know the package).

Well, you don't tell us your linux distribution so I cannot tell the
name of the lib on your system. I suggest you grep the list of
installed packages for "nx" and "xcomp". x2go won't work without any
of them.

x2go-user mailing list

Reply via email to