> From: Andrew Cooper [mailto:andrew.coop...@citrix.com]
> Sent: Thursday, March 8, 2018 2:59 AM
> We currently have MSR_IA32_APICBASE and MSR_IA32_APICBASE_MSR
> which are
> synonymous from a naming point of view, but refer to very different things.
> Rename the x2APIC MSRs to MSR_X2APIC_*, which are shorter constants
> visually separate the register function from the generic APIC name. For the
> case ranges, introduce MSR_X2APIC_LAST, rather than relying on the
> that there are 0x3ff MSRs architecturally reserved for x2APIC functionality.
> For functionality relating to the APIC_BASE MSR, use MSR_APIC_BASE for
> the MSR
> itself, but drop the MSR prefix from the other constants to shorten the
> In all cases, the fact that we are dealing with the APIC_BASE MSR is obvious
> from the context.
> No functional change (the combined binary is identical).
> Signed-off-by: Andrew Cooper <andrew.coop...@citrix.com>
> CC: Jan Beulich <jbeul...@suse.com>
> CC: Roger Pau Monné <roger....@citrix.com>
> CC: Wei Liu <wei.l...@citrix.com>
> CC: Jun Nakajima <jun.nakaj...@intel.com>
> CC: Kevin Tian <kevin.t...@intel.com>
Reviewed-by: Kevin Tian <kevin.t...@intel.com>
Xen-devel mailing list