Subramaniam Krishnan commented on YARN-2385:

Thanks [~sunilg] for taking a look. Other than _killAllAppsInQueue_ and 
_getApplications_, *moveAllApps* also uses _getAppsInQueue_. I agree splitting 
the API makes it more flexible but the question I had is do we have a need now. 
If not maybe we should defer the splitting till we have a concrete use case? If 
you do decide to go ahead with the splitting, invoking *getRunningAppsInQueue + 
getPendingAppsInQueue* instead of just _getAppsInQueue_ should ensure that 
current behaviour is retained for _killAllAppsInQueue_, _getApplications_ and 

> Consider splitting getAppsinQueue to getRunningAppsInQueue + 
> getPendingAppsInQueue
> ----------------------------------------------------------------------------------
>                 Key: YARN-2385
>                 URL: https://issues.apache.org/jira/browse/YARN-2385
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler, fairscheduler
>            Reporter: Subramaniam Krishnan
>              Labels: abstractyarnscheduler
> Currently getAppsinQueue returns both pending & running apps. The purpose of 
> the JIRA is to explore splitting it to getRunningAppsInQueue + 
> getPendingAppsInQueue that will provide more flexibility to callers

This message was sent by Atlassian JIRA

Reply via email to