[ 
https://issues.apache.org/jira/browse/YARN-2385?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14110849#comment-14110849
 ] 

Sunil G commented on YARN-2385:
-------------------------------

Yes [~subru], _moveAllApps_ is also using this api. 

bq. If not maybe we should defer the splitting till we have a concrete use case?

Now the behavior of *getAppsInQueue* in _killAllAppsInQueue_, _getApplications_ 
and _moveAllApps_ is different with Capacity Scheduler and Fair Scheduler. 
Hence I feel that we can split up and make a uniform behavior in all these 
caller sides. How do you feel?

> Consider splitting getAppsinQueue to getRunningAppsInQueue + 
> getPendingAppsInQueue
> ----------------------------------------------------------------------------------
>
>                 Key: YARN-2385
>                 URL: https://issues.apache.org/jira/browse/YARN-2385
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler, fairscheduler
>            Reporter: Subramaniam Krishnan
>              Labels: abstractyarnscheduler
>
> Currently getAppsinQueue returns both pending & running apps. The purpose of 
> the JIRA is to explore splitting it to getRunningAppsInQueue + 
> getPendingAppsInQueue that will provide more flexibility to callers



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to