Wangda Tan commented on YARN-2868:

Thanks for explanation, #3 and [~kasha]'s comment make sense to me.

I would prefer to rename following fields for better accuracy:
1) Rename {{allocationRequestStart}} to {{firstAllocationRequestSentTime}} (I 
misunderstood in my last comment)
2) Rename {{firstContainerAllocation}} to {{firstContainerAllocatedTime}}

And rename setAllocationRequestStart to "trySet.."(or other better name), what 
it tries to do is just trying to do the set.
Return boolean for setAllocationRequestStart make two methods consistent. 
Future caller may need it.


> Add metric for initial container launch time
> --------------------------------------------
>                 Key: YARN-2868
>                 URL: https://issues.apache.org/jira/browse/YARN-2868
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Ray Chiang
>            Assignee: Ray Chiang
>              Labels: metrics, supportability
>         Attachments: YARN-2868-01.patch, YARN-2868.002.patch, 
> YARN-2868.003.patch, YARN-2868.004.patch, YARN-2868.005.patch
> Add a metric to measure the latency between "starting container allocation" 
> and "first container actually allocated".

This message was sent by Atlassian JIRA

Reply via email to