[ 
https://issues.apache.org/jira/browse/YARN-3814?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14681312#comment-14681312
 ] 

Li Lu commented on YARN-3814:
-----------------------------

Thank [~varun_saxena]! 
bq.  So if GenericObjectMapper cannot convert the value and throws an 
Exception, we merely forward whatever came in the request. Hope I am not 
misunderstanding your comment.
OK that's fine. Actually originally I meant parseKeyStrValuesStr and 
parseKeyStrValueStr, but not parseKeyStrValueObj, but never mind. 

bq. Ok. Will move these helper functions to another file.
Actually my key point here is not about separating the file, but to maximize 
code reuse for those parse methods. Part of parseKeyStrValuesStr and 
parseKeyValue are quite similar. If we can reuse most of the code in 
parseKeyValue and not mixing it in the middle of a sequence of parse helper 
methods, I'm totally fine with keeping them in the same file. 

bq. Would a code comment be fine ?
Sure, but it's certainly not harmful to generate one more log, especially when 
FS storage implementation is for debug only? It's up to you though. :)

> REST API implementation for getting raw entities in TimelineReader
> ------------------------------------------------------------------
>
>                 Key: YARN-3814
>                 URL: https://issues.apache.org/jira/browse/YARN-3814
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>    Affects Versions: YARN-2928
>            Reporter: Varun Saxena
>            Assignee: Varun Saxena
>         Attachments: YARN-3814-YARN-2928.01.patch, 
> YARN-3814-YARN-2928.02.patch, YARN-3814-YARN-2928.03.patch, 
> YARN-3814-YARN-2928.04.patch, YARN-3814.reference.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to