[ 
https://issues.apache.org/jira/browse/YARN-5620?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15492925#comment-15492925
 ] 

Varun Vasudev commented on YARN-5620:
-------------------------------------

Thanks for the patch [~asuresh]. +1 except for some minor comment fixes.

1)
{code}
+   * Resource is localized while the container is running - create symlinks.
{code}

Comment is the same for two transition handlers - maybe change slightly to 
provide more context?

2)
{code}
+      // If Container died during an upgrade, dont bother retrying.
{code}
What is this comment for? There’s no change in the code and it looks we're just 
going through the regular retry mechanism.

3)
{code}
+  static class KilledExternallyForReInitTransition extends ContainerTransition 
{
{code}
Maybe this should be renamed? My understanding is that this really is “Killed 
by YARN framework to restart container"

> Core changes in NodeManager to support re-initialization of Containers with 
> new launchContext
> ---------------------------------------------------------------------------------------------
>
>                 Key: YARN-5620
>                 URL: https://issues.apache.org/jira/browse/YARN-5620
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Arun Suresh
>            Assignee: Arun Suresh
>         Attachments: YARN-5620.001.patch, YARN-5620.002.patch, 
> YARN-5620.003.patch, YARN-5620.004.patch, YARN-5620.005.patch, 
> YARN-5620.006.patch, YARN-5620.007.patch, YARN-5620.008.patch, 
> YARN-5620.009.patch, YARN-5620.010.patch, YARN-5620.011.patch, 
> YARN-5620.012.patch, YARN-5620.013.patch, YARN-5620.014.patch, 
> YARN-5620.015.patch
>
>
> JIRA proposes to modify the ContainerManager (and other core classes) to 
> support upgrade of a running container with a new {{ContainerLaunchContext}} 
> as well as the ability to rollback the upgrade if the container is not able 
> to restart using the new launch Context. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to