Below are the steps I've used to resolve my problem for now.

     path to files = /home/{user}/.local/share/zeitgeist/

Short version:
  *  I overwrote /home/dbyrd/.local/share/zeitgeist/* then shutdown my PC via 
the menu. Upon boot the CPU issue was absent. 
  *  zeitgeist daemon cpu usage now equals 0.0 %

More detail:
1. The sqlliteman app (sqlite manager - in ubuntu software center) was used to 
open an old backup copy of activity.sqlite (activity.sqlite.bck). The backup 
sqlite database was easily opened and seemed functional. Next I tried to open 
the activity.sqlite database and I received a corrupt file warning from the 
sqlliteman app. 
2. I backed-up the entire local zeitgeist folder for posterity.
3. I restored my zeitgiest folder overwriting all files in the folder(s). See 
path above.
4. Full Shutdown. Cold boot.
5. The symptoms of the bug are currently absent. My current zeitgeist daemon 
cpu usuage is 0.0 % via htop. Previously htop reported the daemon at 85%-99% 
CPU for hours on end.

I hope this helps.

-- 
You received this bug notification because you are a member of Zeitgeist
Extensions, which is the registrant for Zeitgeist Extensions.
https://bugs.launchpad.net/bugs/722762

Title:
  zeitgeist-daemon using ~100% of CPU

Status in Zeitgeist Framework:
  Invalid
Status in Zeitgeist Extensions:
  Fix Released
Status in “zeitgeist” package in Ubuntu:
  Invalid
Status in “zeitgeist-extensions” package in Ubuntu:
  Fix Released

Bug description:
  I've tried restarting my computer, closing all applications, etc., but
  no matter what System Monitor tells me zeitgeist-daemon is using
  96-100% of the CPU on my i5 Sony Vaio laptop.

To manage notifications about this bug go to:
https://bugs.launchpad.net/zeitgeist/+bug/722762/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~zeitgeist
Post to     : zeitgeist@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zeitgeist
More help   : https://help.launchpad.net/ListHelp

Reply via email to