> -----Original Message-----
> From: Richard Elling [mailto:richard.ell...@gmail.com]
> Sent: 星期二, 九月 20, 2011 3:57
> To: Fred Liu
> Cc: zfs-discuss@opensolaris.org
> Subject: Re: [zfs-discuss] remove wrongly added device from zpool
> more below…
> On Sep 19, 2011, at 9:51 AM, Fred Liu wrote:
> Is this disk supposed to be available?
> You might need to check the partition table, if one exists, to
> determine if
> s0 has a non-zero size.

Yes. I use format to write an EFI label to it. Now this error is gone.
But all four label are failed to unpack under "zdb -l" now.

> This is a bad sign, but can be recoverable, depending on how you got
> here. zdb is saying
> that it could not find labels at the end of the disk. Label 2 and label
> 3 are 256KB each, located
> at the end of the disk, aligned to 256KB boundary. zpool import is
> smarter than zdb in these
> cases, and can often recover from it -- up to the loss of all 4 labels,
> but you need to make sure
> that the partition tables look reasonable and haven't changed.

I have tried zpool import -fFX cn03. But it will do core-dump and reboot about 
1 hour later.

> Unless I'm mistaken, these are ACARD SSDs that have an optional CF
> backup. Let's hope
> that the CF backup worked.

Yes. It is ACARD. You mean push the "restore from CF" button to see what will 

Thanks for your nice help!

zfs-discuss mailing list

Reply via email to