> I renamed those arguments in both methods.
> How can we solve this 2 methods problem ? Deprecation of the old one ? Or
> can we live like this ?
I think this would leave us in the best state:
1. Deprecate beforeCommitHook(), to be subsumed by #2.
2. Change the name of your new function to, e.g., addBeforeCommitHook()
or registerBeforeCommitHook(), and change its signature to
hook, args=(), kws=None, order=0
The mechanics of deprecation are clumsy, but don't worry about #1 -- if we
can agree this is the best outcome, I'll do the deprecation coding+testing.
For more information about ZODB, see the ZODB Wiki:
ZODB-Dev mailing list - ZODB-Dev@zope.org