Okay, I didn't think it'd work, but I tried using a backup.  It
didn't work.  I only have backups of the ZODB with the plone instance
I want to keep.  Unfortunately, it and all the backups seem to be hung
up on finding the broken plone instance in a completely different
ZODB.  I didn't bother making backups of the broken plone instance
because... well, why recover something that's already broken.  The
relation is that the broken plone instance was as far as I could get
with migrating a website from an old version of Plone and I was able
to copy most of the contents over to a new instance of Plone.  All I
used was the "copy" and "paste" inside the ZMI.  I don't understand
why it's still looking for that broken version, but I have no idea how
to alter the "good" site so it stops looking for that broken version
that's no longer there (at least, not in the state that it wants it to


On 3/23/07, Dieter Maurer <[EMAIL PROTECTED]> wrote:
Tim Tisdall wrote at 2007-3-23 16:32 -0400:
>   I tried running a pack on the database via fsrecover.fs and here's
>what I get:
>Recovering Data_fammedmain.fs into Data_fammedmain-recovery.fs
>. 1 . 2 . 3 . 4 . 5 . 6 . 7 . 8 . 9 . 0
>0 bytes removed during recovery
>Packing ...
>Traceback (most recent call last):
> ...
>    return referencesf(self._file.read(dh.plen))
>  File "/opt/Plone-2.5.2/lib/python/ZODB/serialize.py", line 645, in 
>    oid = oid_loaders[reference_type](*args)
>KeyError: 'n'

Looks like the physical structure of your storage is okay but
some object data is corrupted.

Try to restore the storage from a backup.


For more information about ZODB, see the ZODB Wiki:

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to