Jeff Victor wrote:
Carisdad wrote:
[EMAIL PROTECTED] wrote:

On Fri, Aug 18, 2006 at 08:52:29AM +0200, Robert Milkowski wrote:
Hello Brian,

Wednesday, July 26, 2006, 8:31:06 PM, you wrote:

BK> With the performance boosts included in recent solaris versions I'm BK> told that there's not much of a difference between handing the database
BK> raw devices vs. using a filesystem anymore.

BK> To test this out, my customer would like to try both ufs and vxfs
BK> filesystems in the global zone and lofs mount them to a local zone
BK> and test the database on that lofs mount.

BK> Are there any options that should be supplied for the lofs mount and BK> are there any options for the ufs and/or vxfs mounts that should be
BK> employed to assure the performance should be close to raw devices?


1. lofs is probably a bad idea - mount them directly into a zone


lofs is the only supported option for vxfs.

przemol
_______________________________________________

While lofs is the only officially supported option, mounting directly in the zone can be accomplished with a work-around. see: http://seer.entsupport.symantec.com/docs/276134.htm

That's interesting. Do you know if there is also a work-around that allows you to assign a VxVM device into a non-global zone, and then mount it with VxFS when the zone boots?


-------------------------------------------------------------------------- Jeff VICTOR Sun Microsystems jeff.victor @ sun.com
OS Ambassador            Sr. Technical Specialist
Solaris 10 Zones FAQ: http://www.opensolaris.org/os/community/zones/faq --------------------------------------------------------------------------

I hadn't tried this, or even thought of it, really. Playing around, though, it doesn't seem like it would be easy to do. I tried creating a zone and adding various device resources (/dev/vx/*, /dev/vx/dsk/*, /dev/vx/dsk/mydg/*, ...) to the zonecfg, but they don't get created when the zone boots. I then manually created the directories for <zonepath>/dev/vx/(dsk|rdsk)/mydg and used mknod to create the devices from the global zone. This gave me raw access to the devices

I can then run /usr/bin mount, but it complains about not being the correct fstyp (vxfs).

So I added an lofs mount for /etc/fs/vxfs to the local zone, and ran /etc/fs/vxfs/mount directly and get "UX:vxfs mount: ERROR: V-3-25791: mount: is not supported on a localzone". I looked a little bit further into trying to use dtrace to watch for the fbt::zone_lookup:entry/return call or syscall::zone:entry/return and using destructive actions to trick mount into believing it was in the global, but couldn't quite get it worked out.

At that point I decided it was maybe a bit too complicated to really call anything a work-around. ;-)

But it was fun to try....

-Andy
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to