Jerry Jelinek wrote:
> Lori Alt wrote:
>> Anybody know how to get "zoneadm clone" to use
>> zfs cloning?  I've got a zone (z1) whose root is a zfs dataset.
>> I configure a new zone (z2) and try to make z2 a clone of z1:
>> # zoneadm -z z2 clone z1
>> This works, but the clone is constructed by copying z1, not
>> by doing a zfs clone.  What am I missing?
> Lori,
> I have a few questions.
> First, what OS are you running?  The built-in support only
> exists in nv right now.
I'm running S10U6 (build 5).  I guess that answers
my question.  I thought the zone clone changes
had been backported. 



> When you say "zone root", what do you mean?  Is the z1
> zonepath a dataset or did you do something special to make
> z1's {zonepath}/root into a dataset?  We don't support the latter
> yet.
> Is the parent of the z2 zonepath a dataset?
> When you installed z1, did it tell you it was creating
> a dataset?  If not, then you don't have the zfs datasets
> set up correctly for this to work.
> Would both zonepath datasets be in the same pool?
> As an FYI, I just tried a clone on b95 and it worked fine.
> Thanks,
> Jerry

zones-discuss mailing list

Reply via email to