On Tue, 08 Dec 2009 18:31:55 +0100, xx <david.sc...@autohandle.com> wrote:

> i'm still not doing something right:
> init...@dogpatch:~# pkg install SUNWs10brand
> Creating Plan
> pkg: The following pattern(s) did not match any packages in the current 
> catalog.
> Try relaxing the pattern, refreshing and/or examining the catalogs:
>       SUNWs10brand
> init...@dogpatch:~# pkg info -r "*" 2>&1 | grep brand
>       pkg://development/SUNWipkg-brand
> init...@dogpatch:~# pkg info -r "*" 2>&1 | grep s10
> init...@dogpatch:~# pkg publisher
> PUBLISHER                             TYPE     STATUS   URI
> development              (preferred)  origin   online   
> http://pkg.opensolaris.org/dev/
> extra                                 origin   online   
> https://pkg.sun.com/opensolaris/extra/
> opensolaris.org                       origin   online   
> http://pkg.opensolaris.org/release/
> init...@dogpatch:~#

I think thats because your publisher local name is not the default,
I did the same today and it worked

batsc...@osoldev:/usr/lib/brand$ pkg info -r "*" 2>&1 | grep brand

my publisher is this:

batsc...@osoldev:/usr/lib/brand$  pkg publisher
PUBLISHER                             TYPE     STATUS   URI
opensolaris.org          (preferred)  origin   online   
blastwave                             origin   online   
osol-contrib                          origin   online   
sunfreeware.com                       origin   online   

I believe there were some problems recently when the local name did
not matched the "offical" publishers name.


It is always possible to agglutinate multiple separate problems
into a single complex interdependent solution.
In most cases this is a bad idea.
zones-discuss mailing list

Reply via email to