Following is the output from the log file when i try to attach the zone 

 /var/tmp/s10zone1.attach_log.djaOxj
[Wednesday, April  6, 2011 08:49:45 PM CDT] Log File: 
/var/tmp/s10zone1.attach_log.djaOxj
[Wednesday, April  6, 2011 08:49:45 PM CDT] Attaching...
[Wednesday, April  6, 2011 08:49:45 PM CDT] gzipped cpio archive
[Wednesday, April  6, 2011 08:49:46 PM CDT]
[Wednesday, April  6, 2011 08:49:46 PM CDT] Analysing the archive
[Wednesday, April  6, 2011 08:50:49 PM CDT] cd "/zones" && gzcat 
"/home/user1/db_zone.cpio.gz" | cpio -idmfE /var/tmp/fs.cpio.NkaWyj
cpio: Cannot mknod() "db_zone/dev/cpu/self/cpuid", errno 22, Invalid argument
cpio: Cannot chown() "db_zone/dev/cpu/self/cpuid", errno 2, No such file or 
directory
cpio: Unable to reset modification time for "cpuid", errno 2, No such file or 
directory
cpio: Cannot chmod() "db_zone/dev/cpu/self/cpuid", errno 2, No such file or 
directory
1405280 blocks
4 error(s)
[Wednesday, April  6, 2011 08:52:02 PM CDT] HWCAP: moe: 
/zones/db_zone/root/lib/libc.so.1: open failed: No such file or directory
[Wednesday, April  6, 2011 08:52:02 PM CDT] ERROR: The image was created with 
an incompatible libc.so.1 hwcap lofs mount.
       The zone will not boot on this platform.  See the zone's
       documentation for the recommended way to create the archive.


After steve told me i checked the logs and found that lib files are missing 
from the zone which was being migrated (do not know the reason for it ).. and i 
just copied lib files from /lib to /zones/root/lib/  .. it went lil ahead but 
then it gave
me following error  


************************************************************************************************
tail -f /var/tmp/s10zone1.attach_log.9.aW9j
[Wednesday, April  6, 2011 09:14:56 PM CDT] Log File: 
/var/tmp/s10zone1.attach_log.9.aW9j
[Wednesday, April  6, 2011 09:14:56 PM CDT] Attaching...
[Wednesday, April  6, 2011 09:14:56 PM CDT] gzipped cpio archive
[Wednesday, April  6, 2011 09:14:56 PM CDT]
[Wednesday, April  6, 2011 09:14:56 PM CDT] Analysing the archive
[Wednesday, April  6, 2011 09:16:10 PM CDT] cd "/zones" && gzcat 
"/home/user1/db_zone.cpio.gz" | cpio -idmfE /var/tmp/fs.cpio.Daa4.j
cpio: Cannot mknod() "db_zone/dev/cpu/self/cpuid", errno 22, Invalid argument
cpio: Cannot chown() "db_zone/dev/cpu/self/cpuid", errno 2, No such file or 
directory
cpio: Unable to reset modification time for "cpuid", errno 2, No such file or 
directory
cpio: Cannot chmod() "db_zone/dev/cpu/self/cpuid", errno 2, No such file or 
directory
1734472 blocks
4 error(s)
[Wednesday, April  6, 2011 09:17:39 PM CDT] Missing sbin/zonename at 
/zones/db_zone/root
[Wednesday, April  6, 2011 09:17:39 PM CDT] Is this a sparse zone image?  The 
image must be whole-root.
[Wednesday, April  6, 2011 09:17:39 PM CDT] Missing usr/bin/chmod at 
/zones/db_zone/root
[Wednesday, April  6, 2011 09:17:39 PM CDT] Is this a sparse zone image?  The 
image must be whole-root.
[Wednesday, April  6, 2011 09:17:39 PM CDT]   Sanity Check: FAILED (see log for 
details).
[Wednesday, April  6, 2011 09:17:39 PM CDT] ERROR: *** Attach FAILED ***

***********************************************************************************************


so does this means we cannot migrate a sparse root zone to Solaris 11 express 
server ?  or is it i 'm doing something wrong ?
-- 
This message posted from opensolaris.org
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to